Forums Últimos mensajes - Powered by IBM
 

Anidar formula

12/04/2005 - 20:15 por osalazarg | Informe spam
Buenas Tardes, espero que alguien me pueda ayudar por favor , a anidar
esta formula ya que necesito buscar la celda en que se encuentre c1, para
poder usar la formula de buscarh, la formula original me funciona bien ,
pero al incorporarle el coindcidir no me funciona, esta es la formula
anterior:



=EXTRAE(BUSCARH(C1,SOLUCIONES!A2:A389,2,0),5,8)

necesito por medio de coincidir me traiga la celda donde empezara la
funcion buscarh A2,A3,A4,A5,A6..ETC.


=EXTRAE(BUSCARH(C1,SOLUCIONES!A&(INDIRECTO(COINCIDIR(C1,SADFI!A2:A346,0))):A389,2,0),5,8)
 

Leer las respuestas

#1 victorbcn1952NO
12/04/2005 - 20:58 | Informe spam
Hay algo que no me 'liga'. Dices que te funciona la fórmula, pero un
BUSCARH requiere un rango de partida horizontal, y tú tienes A2:A389. Creo
que eso es más propio de un BUSCARV. Pero en este caso también te fallará
la fórmula, ya que A2:A389 no acepta un argumento de salida 2;0 (en el
rango A:A no puedes pedir que te devuelva la 2ª columna a la derecha).

Si realmente necesitas un BUSCARH, prueba con =BUSCARH(C1;A2:CC2;2;0)
Cambia CC por otra columna más a la derecha, si es necesario.

Y si lo que necesitas es BUSCARV, coloca =BUSCARV(C1;A2:B389;2;0)

Con eso quizá te funcione el resto de la fórmula; si no, vuelve a
escribir...

:-)


sago wrote:

Buenas Tardes, espero que alguien me pueda ayudar por favor , a anidar
esta formula ya que necesito buscar la celda en que se encuentre c1, para
poder usar la formula de buscarh, la formula original me funciona bien ,
pero al incorporarle el coindcidir no me funciona, esta es la formula
anterior:



=EXTRAE(BUSCARH(C1,SOLUCIONES!A2:A389,2,0),5,8)

necesito por medio de coincidir me traiga la celda donde empezara la
funcion buscarh A2,A3,A4,A5,A6..ETC.





=EXTRAE(BUSCARH(C1,SOLUCIONES!A&(INDIRECTO(COINCIDIR(C1,SADFI!A2:A346,0))):A389,2,0),5,8)

Preguntas similares