Forums Últimos mensajes - Powered by IBM
 

anidar más de siete niveles.

28/02/2006 - 21:44 por Diana | Informe spam
En la celda B1 tengo la siguiente fórmula:

=SI(A1/01/2006;+K7;SI(A1/02/2006;+K7*2;SI(A1/03/2006;+K7*3;SI(A1/04/2006;+K7*4;SI(..

y así hasta cubrir los doce meses del año y llegar a diciembre 2006, donde
quedaría K7*12. Cuando pasé la anidación Nº7 se me arruinó la fórmula porque
no pude anidar más.
Cómo hago para cubrir con una sola fórmula los doce meses del año?
Encontré en una pregunta de big en el foro del día 21/02/06, una respuesta
de Joaquín que para resolver divide la fórmula en dos celdas distintas . KL
dice que hay varias soluciones posibles conociendo más detalles de la
fórmula.
Se puede resolver esta fórmula en una sola teniendo en cuenta lo que
necesito calcular?
Muchas gracias
Diana
 

Leer las respuestas

#1 Héctor Miguel
28/02/2006 - 21:52 | Informe spam
hola, Diana !

En la celda B1 tengo la siguiente formula:
=SI(A1/01/2006;+K7;SI(A1/02/2006;+K7*2;SI(A1/03/2006;+K7*3;SI(A1/04/2006;+K7*4;SI(...
... hasta cubrir los doce meses del a#o... donde quedaria K7*12.
Cuando pase la anidacion... 7 se me arruino la formula porque no pude anidar mas.
Como hago para cubrir con una sola formula los doce meses del a#o? [...]



prueba con: =k7*mes(a1)

saludos,
hector.

Preguntas similares