Forums Últimos mensajes - Powered by IBM
 

Ayuda con esta formula

29/12/2006 - 03:00 por Conchavandito | Informe spam
Hola a todos,
En la celda A1 tengo el valor de = 26
Quiero sumar la multiplicación de cada uno de sus digitos por un peso
= {5,4}
= 2*5 + 6*4 = 34

Intente con esta fórmula:

= SUMAPRODUCTO( {EXTRAE(A1,1,1),EXTRAE(A1,2,1)} , {5,4} )
y me indica que mi fórmula tiene un error y no permite ejecutarla

ingrese esta prueba :
= SUMAPRODUCTO( {2,6} , {5,4} )
y me arroja el valor esperado = 34

Si alguien puede ayudarme estaré muy agradecido
 

Leer las respuestas

#1 Héctor Miguel
29/12/2006 - 03:14 | Informe spam
hola, 'anonimo/a' !

En la celda A1 tengo el valor de = 26
Quiero sumar la multiplicación de cada uno de sus digitos por un peso = {5,4} = 2*5 + 6*4 = 34
Intente con esta formula:
= SUMAPRODUCTO( {EXTRAE(A1,1,1),EXTRAE(A1,2,1)} , {5,4} )
y me indica que mi formula tiene un error y no permite ejecutarla
ingrese esta prueba: = SUMAPRODUCTO( {2,6} , {5,4} )
y me arroja el valor esperado = 34



1) los 'valores' que se ponen entre corchetes { ... } son valores 'constantes' [no valores que dependan del re/calculo del modelo]
o sea, no puedes usar la expresion: -> {EXTRAE(A1,1,1),EXTRAE(A1,2,1)} [entre corchetes]

2) no estoy muy seguro que tu separador de filas/columnas en matrices constantes sea el mismo que para separar los argumentos
en mi caso, en matrices constantes las filas las separo por \ y las columnas por ; -???-

3) corrige donde los separadores sean distintos [de tus usos/costumbres/configuracion regional/...] -?-
=sumaproducto(--extrae(a1,{1\2},1),{5\4}) <= nota el doble-menos que antecede a la funcion extrae

si cualquier duda [o informacion adicional]... comentas ?
saludos,
hector.

Preguntas similares