Ayuda Para Encontar Minutos de Retardo.

07/02/2006 - 04:09 por David Nava | Informe spam
Hola amigos, espero que alguien me pueda ayudar a encontrar una formula o
macro para resolver el siguiente problema: durante un mes (30 dias) un
empleado checa su entrada al trabajo a las 08:00 hrs. Mi problema es sumar
los minutos que llega tarde, por ejemplo 08:10, 08:05, 08:13,
etc...resultado: 10+05+13,
gracias de antemano.
 

Leer las respuestas

#1 KL
07/02/2006 - 12:51 | Informe spam
Hola David,

Suponiendo que...
1) las horas de entrada estan introducidas como horas 8:10 y no como texto "8:10"
2) las horas de entrada estan introducidas sin fecha (en la barra de formulas aparecen como 00/01/1900 08:10:00 o parecido)
3) no queres que las los minutos de tardanza se compensen con los de llegadas antes de las 8:00
4) las horas estan introducidas en el rango [A1:A10]

Solo necesitas hacer lo siguiente:

1) en una celda, digamos [C1] usar la siguiente formula:
=SUMAR.SI(A1:A10;">08:00")-CONTAR.SI(A1:A10;">08:00")*"08:00"

mas opciones, pero bastante mas lentas:
=SUMAPRODUCTO(--(A1:A10>--"08:00");A1:A10-"08:00")
=SUMAPRODUCTO(--(A1:A10>NSHORA(8;0;0));A1:A10-NSHORA(8;0;0))

2) formatear esa celda ([C1]) con el formato [m]:ss o incluso [m]
- selecciona la celda
- menu Formato>Celda...
- pestana: Numero
- categoria: Personalizada
- tipo: [m]

Saludos,
KL


"David Nava" wrote in message news:%
Hola amigos, espero que alguien me pueda ayudar a encontrar una formula o
macro para resolver el siguiente problema: durante un mes (30 dias) un
empleado checa su entrada al trabajo a las 08:00 hrs. Mi problema es sumar
los minutos que llega tarde, por ejemplo 08:10, 08:05, 08:13,
etc...resultado: 10+05+13,
gracias de antemano.


Preguntas similares