Forums Últimos mensajes - Powered by IBM
 

Ayuda para sumar subtotales y totales

19/01/2006 - 16:31 por roteggor | Informe spam
Hola Grupo:
Ayer KL, me enseñó a sumar una hoja de Excel en la que consta todos los dias
del mes de febrero 2006
dividos por semanas naturales, con 9 columnas con distintos conceptos y una
columna total semanal (en total 10 columnas) y 38 filas.
Esta hoja, a su vez, tiene un subtotal al final de gastos semanales -en cada
una de las 9 columnas
Con la formula que copìo mas abajo esto queda resuelto
=SUBTOTALES(9;E$5:E$9)
=SUMA(E10:M10)
=SUBTOTALES(9;E$11:E$17)
=SUMA(E18:M18)
=SUBTOTALES(9;E$19:E$25)
=SUMA(E26:M26)
=SUBTOTALES(9;E$27:E$33)
=SUMA(E34:M34)
=SUBTOTALES(9;E$35:E$36)
=SUMA(E37:M37)
El problema lo tengo que ahora quiero sumar las cinco semanas, es decir,
(E10+E18+E26+E34+E37) y arrastrar este criterio en las columnas
(F,G,H,I,J,K,L,M, y sumar los subtotales semanales que figuran en la columna
N.
Yo había intentado con esta formula, pero no funciona.

=SUBTOTALES(9;E$10+E$18+E$26+E$34+E$37:M$10+M$18+M$26+M$34+M$37)

Perdonad pero no tengo los conocimientos suficientes para poder interpretar
vuestras explicaciones si no me lo explicais en plan principiante. Muchas
gracias por vuestra ayuda.
Roteggor
 

Leer las respuestas

#1 Héctor Miguel
20/01/2006 - 00:42 | Informe spam
hola, roteggor !

puedes utilizar la misma funcion subtotales(9;...) incluyendo DESDE la celda inicial en cada columna ;)
si analizas el 'paso 4' de la segunda propuesta de KL... veras que el 'penultimo' subtotal -> ncluye TODO el rango ;)
o puedes consultar la ayuda en linea de excel {F1} con relacion a la funcion subtotales ;) encontraras que...
-> cuando subtotales 'encuentra' otros subtotales [o subtotales 'anidados'] los omite para no duplicar los calculos ;)

para el caso que planteas [p.e. para la columna 'E'] suponiendo que la siguiente fila es la numero 38...
[E38] =subtotales(9;e$5:e$37) <= esta la copias a las columnas (F,G,H,I,J,K,L,M)

ya podras sumar los subtotales semananes de la fila 38 ;)

si cualquier duda... comentas ?
saludos,
hector.

mensaje original ==> ... KL, me ense#o a sumar... Con la formula que copio mas abajo...
=SUBTOTALES(9;E$5:E$9)
=SUMA(E10:M10)
=SUBTOTALES(9;E$11:E$17)
=SUMA(E18:M18)
=SUBTOTALES(9;E$19:E$25)
=SUMA(E26:M26)
=SUBTOTALES(9;E$27:E$33)
=SUMA(E34:M34)
=SUBTOTALES(9;E$35:E$36)
=SUMA(E37:M37)
... ahora quiero sumar las cinco semanas, es decir, (E10+E18+E26+E34+E37)
y arrastrar este criterio en las columnas (F,G,H,I,J,K,L,M) y sumar los subtotales semanales que figuran en la columna N.
Yo habia intentado con esta formula, pero no funciona.
=SUBTOTALES(9;E$10+E$18+E$26+E$34+E$37:M$10+M$18+M$26+M$34+M$37) [...]

Preguntas similares