Forums Últimos mensajes - Powered by IBM
 
Tags Palabras claves

Buscador

19/05/2005 - 17:37 por richi | Informe spam
Hola amigos,

tengo el siguiente problema con el buscador que estoy implementando,

lo hago mediante una consulta "sencilla" sobre todo lo que el usuario
introduce, no busco por palabras ni nada por el esto.

El problema viene con los acentos, he tratado la cadena a buscar
sustituyendo las vocales acentuadas por "_" (caracter comodin para access).
El problema es que los resultados no coinciden si aplico esta tecnica y si
no la uso.
Ademas esto genera un problema, porque luego quiero poner en negrita el
resultado y, si escribo una palabra sin acento, y sale con acento no tengo
forma de encontrarla para resaltarla.

Alguien sabe como puede solucionarse esto de alguna forma?

Gracias.
 

Leer las respuestas

#1 Matias Laino
24/05/2005 - 16:43 | Informe spam
Pensaste en utilizar codigos ascii para estos casos? por ejemplo en vez de
utilizar mat_as utilizar "mat" & chr(161) & "as"
Saludos

"richi" escribió en el mensaje
news:
Hola amigos,

tengo el siguiente problema con el buscador que estoy implementando,

lo hago mediante una consulta "sencilla" sobre todo lo que el usuario
introduce, no busco por palabras ni nada por el esto.

El problema viene con los acentos, he tratado la cadena a buscar
sustituyendo las vocales acentuadas por "_" (caracter comodin para


access).
El problema es que los resultados no coinciden si aplico esta tecnica y si
no la uso.
Ademas esto genera un problema, porque luego quiero poner en negrita el
resultado y, si escribo una palabra sin acento, y sale con acento no tengo
forma de encontrarla para resaltarla.

Alguien sabe como puede solucionarse esto de alguna forma?

Gracias.




Preguntas similares