Forums Últimos mensajes - Powered by IBM
 

Buscar un texto, dentro cadenas de texto y en dos columna de diferente rango.

03/06/2006 - 09:43 por Kanduleitor | Informe spam
Buenas. El problema es el siguiente
Quiero comparar el texto exacto (mayusculas, minusculas, acentos,
espacios en blanco) de las celdas que pertenece a la columna (C1:C27)
mas pequeña. Con una columna (A1:A1000) mas grande, en la cual hay
celdas que tienen el contenido exacto de la celda que pertenece a la
columna (C1:C27) dentro de la cadena de texto que pertenece a la celda
de la columna "A".

A B C
_Pépé Ok ECa mión
Pépe NO Ok pepe
ECa mión Ok Pépé
XX uno_ NO Ok jejeje
qwert NO OK
jeje NO OK
jéjéjé NO OK
jejeje OK
pepe_h OK

Lo he intentado con casi dotas las funciones de texto, buscar,
encontrar pero lo unico que he podido es comparar una celda con otra a
la vez. Pero no una celda con una matriz.
en la celda lo he conseguido con:
=SI(ESERROR(ENCONTRAR(C1;A1));"NO OK";"OK")

Con las formulas matriciales no he podido diferenciar acentos,
mayusculas...
No se utilizar las macros... pero si no hay otro remedio
aprenderemos...

Gracias a todos.
 

Leer las respuestas

#1 KL
03/06/2006 - 15:27 | Informe spam
Hola Kanduleitor,

Pues es justo lo que yo sospechaba, pero tu ejemplo inicial no encajaba del todo con la descripcion que ponias (no recogia los casos de texto buscado dentro de otras cadenas de texto) - las tres formulas propuestas por HM y KL devolvian exactamente los resultados que exponias para tu ejemplo.

Ahora bien, vistas tus nuevas aclaraciones podrias probar las siguientes formulas:

=SI(A1="";"";SI(SUMAPRODUCTO(--ESNUMERO(ENCONTRAR(A1;$C$1:$C$1000)));"OK";"NO OK"))
distingue entre mayusculas y minusculas, pero lenta: 2.389,76 milisegundos en 1.000 filas

=SI(A1="";"";SI(ESNUMERO(COINCIDIR("*"&A1&"*";$C$1:$C$1000;0));"OK";"NO OK"))
no distingue entre mayusculas y minusculas (ya se que no es lo que andas buscando, pero por si la moscas), pero rapida: 200,39 milisegundos en 1.000 filas

Saludos,
KL


"Kanduleitor" wrote in message news:
Buenas. El problema es el siguiente
Quiero comparar el texto exacto (mayusculas, minusculas, acentos,
espacios en blanco) de las celdas que pertenece a la columna (C1:C27)
mas pequeña. Con una columna (A1:A1000) mas grande, en la cual hay
celdas que tienen el contenido exacto de la celda que pertenece a la
columna (C1:C27) dentro de la cadena de texto que pertenece a la celda
de la columna "A".

A B C
_Pépé Ok ECa mión
Pépe NO Ok pepe
ECa mión Ok Pépé
XX uno_ NO Ok jejeje
qwert NO OK
jeje NO OK
jéjéjé NO OK
jejeje OK
pepe_h OK

Lo he intentado con casi dotas las funciones de texto, buscar,
encontrar pero lo unico que he podido es comparar una celda con otra a
la vez. Pero no una celda con una matriz.
en la celda lo he conseguido con:
=SI(ESERROR(ENCONTRAR(C1;A1));"NO OK";"OK")

Con las formulas matriciales no he podido diferenciar acentos,
mayusculas...
No se utilizar las macros... pero si no hay otro remedio
aprenderemos...

Gracias a todos.

Preguntas similares