Forums Últimos mensajes - Powered by IBM
 

Combinar dias y horas2

25/11/2005 - 22:42 por Leandro | Informe spam
Hola Willian al meter esa formula no me muestra ningun resultado he probado
a cambiar el final por las comillas o sea
=SI(Y(A1=VALOR("1/12/2005");B1>=VALOR("08:00");B1<=VALOR("12:00"));"";C1)
pero así tampoco funciona el tema es que quiero en una factura de telefono
separar las llamadas efectuadas a partir de las 20:00 hasta las 08:00 del
dia siguiente.que en la casilla C1 tengo el importe.
No se si me exprese bien
Un Saludo
Leandro
 

Leer las respuestas

#1 David
26/11/2005 - 00:10 | Informe spam
Disculpad que me meta, Leandro, pero te dejo algunas ideas. Tú haces el
resto ;-).

La función Valor en tu fórmula, te retornará un cero, pues al utilizarla en
la forma VALOR("1/12/2005"), estás pidiendo el valor de un string, el cual es
nulo. Deberías usar una expresión como esta:
ENTERO(A1)þCHANUMERO("25/11/2005").
Observa que ENTERO es necesario, pues necesitas descartar la parte
fraccionaria que corresponde a las horas y minutos.

Por otro lado, tienes un error similar cuando tratas de comparar las horas y
pones B1>=VALOR("08:00"). ¿Qué tienes en B1? ¿Una hora? entonces deberías
poner B1>HORANUMERO("08:00")... ¿Una fecha? entonces deberías poner
HORA(B1)/24+MINUTO(B1)/60/24>HORANUMERO("08:00").

¿ves? sólo es cuestión de pensar como Excel...

"Leandro" escribió:

Hola Willian al meter esa formula no me muestra ningun resultado he probado
a cambiar el final por las comillas o sea
=SI(Y(A1=VALOR("1/12/2005");B1>=VALOR("08:00");B1<=VALOR("12:00"));"";C1)
pero así tampoco funciona el tema es que quiero en una factura de telefono
separar las llamadas efectuadas a partir de las 20:00 hasta las 08:00 del
dia siguiente.que en la casilla C1 tengo el importe.
No se si me exprese bien
Un Saludo
Leandro



Preguntas similares