Forums Últimos mensajes - Powered by IBM
 

como cuento cuantas veces aparece una cadena en otra?

01/09/2007 - 10:54 por Juan Gustavo Fogelman | Informe spam
Buenas gente
como cuento cuantas veces aparece una cadena en otra?
necesito un integer...
tipo:
A1: "42; "
A2: "00; 01; 42; 42; 45; "
A3: una formula que me de como resultado 2, luego de comprobar que el A2
esta 2 veces A1

Gracias gente
 

Leer las respuestas

#1 KL
01/09/2007 - 20:51 | Informe spam
Tal vez algo asi:

=(LARGO(A1)-LARGO(SUSTITUIR(A1;"
"&42&";";"")))/(LARGO(42)+2)+(IZQUIERDA(A1;LARGO(42)+1)B&";")

o asi:

=SUMAPRODUCTO(--(ESPACIOS(EXTRAE(SUSTITUIR($A$1;";";REPETIR("
";LARGO($A$1)));LARGO($A$1)*(FILA(INDICE(A:A;1):INDICE(A:A;1+LARGO(A1)-LARGO(SUSTITUIR(A1;";";""))-1))-1)+1;LARGO($A$1)))="42"))

Saludos,
KL



"Juan Gustavo Fogelman" wrote in message
news:
Buenas gente
como cuento cuantas veces aparece una cadena en otra?
necesito un integer...
tipo:
A1: "42; "
A2: "00; 01; 42; 42; 45; "
A3: una formula que me de como resultado 2, luego de comprobar que el A2
esta 2 veces A1

Gracias gente

Preguntas similares