Forums Últimos mensajes - Powered by IBM
 

Cómo obtener promedio de un rango con celdas en blanco?

31/05/2010 - 23:12 por Alex | Informe spam
Si quiero obtener el promedio de todo lo que aparezca en cierta columna,
pero SIN TOMAR EN CUENTA las celdas vacías o cuyo valor sea 0???

Por ejemplo, en B301, quiero que aparezca el valor de
=PROMEDIO(B2:B300), pero hasta ahora sólo tengo valores en los registros
B2:B8. La fórmula me está promediando todas las celdas siguientes, con
valor de 0. Cómo evitarlo?
 

Leer las respuestas

#1 Aladino
01/06/2010 - 00:23 | Informe spam
Hola, Alex

Si utilizas Excel 2007 puedes usar la función PROMEDIO.SI.CONJUNTO de
esta manera:

=PROMEDIO.SI.CONJUNTO(B2:B300;B2:B300;">0";B2:B300;"<>""")

En versiones anteriores hay distintas maneras de conseguir el mismo
resultado. Te propongo una fórmula matricial como la siguiente:

=PROMEDIO(SI(B2:B300<>0;B2:B300))

Para obtener el resultado esperado has de pulsar ctrl + mayus+intro.

Tenemos un curso gratuito en Excel 2007 via mail por si quieres
aprender un poco más sobre Excel.

www.5incoaprendices.com

On 31 mayo, 23:12, Alex wrote:
Si quiero obtener el promedio de todo lo que aparezca en cierta columna,
pero SIN TOMAR EN CUENTA las celdas vacías o cuyo valor sea 0???

Por ejemplo, en B301, quiero que aparezca el valor de
=PROMEDIO(B2:B300), pero hasta ahora sólo tengo valores en los registros
B2:B8. La fórmula me está promediando todas las celdas siguientes, con
valor de 0. Cómo evitarlo?

Preguntas similares