Forums Últimos mensajes - Powered by IBM
 

Como puedo hacer promedios en "x" intervalos de filas???

19/07/2007 - 01:40 por Edo | Informe spam
Qusiera saber sialguin me puedria comentar como hacer promedios cada "x"
numero de filas, es decir:

por ejemplo

Celda B1 =PROMEDIO(A1:A5)
Celda B2 =PROMEDIO(A6:A10)
Celda B3 =PROMEDIO(A11:A15)
Celda B4 =PROMEDIO(A16:A20)
...
...
etc.

si alguien me podria ayudar se lo agradeceria.
 

Leer las respuestas

#1 David
19/07/2007 - 02:58 | Informe spam
Hola, Edo.

Primero, considera que yo utilizo la coma por separador. Si las fórmulas
que te doy no funcionan, prueba cambiar las comas por punto y comas.

Supongamos que vas a calcular el promedio en grupos de 5 en 5 celdas, para
la columna A, a partir de la fila 1. Podrías concatenar la dirección del
rango que vas a promediar con la siguiente expresión en la celda B1:

=CONCATENAR("A",1+(FILA(A1)-1)*5,":A",1+(FILA(A1)-1)*5+5-1)

Pruébala en tu hoja, luego la copias y revisas para verificar si es
correcta. El siguiente paso sería utilizar la función Indirecto(...) para
convertira en un rango que la función Promedio te pueda interpretar. La
fórmula en B1 quedaría así:

=PROMEDIO(INDIRECTO(CONCATENAR("A",1+(FILA(A1)-1)*5,":A",1+(FILA(A1)-1)*5+5-1)))

y la copias hasta donde sea necesario.

Ahora hagamos variantes. Si no fuera la columna A, sino la C, sólo tendrías
que cambiar las letras A que están entre comillas:

=PROMEDIO(INDIRECTO(CONCATENAR("C",1+(FILA(A1)-1)*5,":C",1+(FILA(A1)-1)*5+5-1)))

Observa que no es necesario cambiar la dirección de celda A1. Ésta es solo
referencia, y no te afectaría.

Ahora pensemos en la columna C, pero en grupos de 6. En este caso cambia
todos los 5 por 6:

=PROMEDIO(INDIRECTO(CONCATENAR("C",1+(FILA(A1)-1)*6,":C",1+(FILA(A1)-1)*6+6-1)))

Por último, pensemos en iniciar en la fila 3, en lugar de la fila 1, cambia
todos los 1+ por 3+:

=PROMEDIO(INDIRECTO(CONCATENAR("C",3+(FILA(A1)-1)*6,":C",3+(FILA(A1)-1)*6+6-1)))

Haz varias pruebas y comentas.

Saludos.



"Edo" escribió:


Qusiera saber sialguin me puedria comentar como hacer promedios cada "x"
numero de filas, es decir:

por ejemplo

Celda B1 =PROMEDIO(A1:A5)
Celda B2 =PROMEDIO(A6:A10)
Celda B3 =PROMEDIO(A11:A15)
Celda B4 =PROMEDIO(A16:A20)
...
...
etc.

si alguien me podria ayudar se lo agradeceria.

Preguntas similares