Forums Últimos mensajes - Powered by IBM
 

comparar celdas

09/06/2005 - 11:20 por a | Informe spam
Buenos dias.
Tengo una hoja de calculo,
lunes martes miercoles jueves viernes
1 a d b 1 9
2 b 1 d a a
3 c 1 3 b j
4 b j 9 2 d

Necesito hacer una busqueda rebundante, es decir, que me marque cuales
celdas estan repetidas.
Si cualquiera del lunes esta repetida en el martes miercoles jueves y
viernes
si cualquiera del martes esta repetida en el miercoles , etc
etc.
Sobre todo seria interesante que me las marcase o resaltase de alguna manera
las que están repetidas..
No se si me he explicado con claridad.

PD no controlo mucho sobre macros ni funciones.
Un saludo y gracias anticipadas.
 

Leer las respuestas

#1 Fernando Arroyo
09/06/2005 - 12:26 | Informe spam
Quizás te sirva el formato condicional. Por ejemplo, para que aparezcan con un color determinado las celdas cuyo valor se encuentre repetido en el rango A2:E5, tendrías que:
- hacer Formato > Formato condicional
- en 'Condición 1' seleccionar "Fórmula"
- poner como fórmula:

=CONTAR.SI($A$2:$E$5;A2)>1

- pulsar el botón 'Formato' y establecer el color que deberán tener las celdas duplicadas.

También sería posible aprovechar las tres condiciones que admite el formato condicional para diferenciar las celdas cuyo valor está duplicado, las que se encuentran dos veces y las que están tres o más veces. Las fórmulas para las condiciones serían:

=CONTAR.SI($A$2:$E$5;A2)=2

=CONTAR.SI($A$2:$E$5;A2)=3

=CONTAR.SI($A$2:$E$5;A2)>3

Un saludo.


Fernando Arroyo
MS MVP - Excel

"a" escribió en el mensaje news:
Buenos dias.
Tengo una hoja de calculo,
lunes martes miercoles jueves viernes
1 a d b 1 9
2 b 1 d a a
3 c 1 3 b j
4 b j 9 2 d

Necesito hacer una busqueda rebundante, es decir, que me marque cuales
celdas estan repetidas.
Si cualquiera del lunes esta repetida en el martes miercoles jueves y
viernes
si cualquiera del martes esta repetida en el miercoles , etc
etc.
Sobre todo seria interesante que me las marcase o resaltase de alguna manera
las que están repetidas..
No se si me he explicado con claridad.

PD no controlo mucho sobre macros ni funciones.
Un saludo y gracias anticipadas.


Preguntas similares