Forums Últimos mensajes - Powered by IBM
 

Consulta sobre Aplicacion

09/02/2006 - 19:02 por Hernan Fuccillo | Informe spam
Hola, tengo una aplicacion hecha que gestiona trabajos de replicacion de
archivos entre N servidores. El problema es que si yo compilo la solucion y
me ejecuta el proyecto, todo funciona perfecto, pero cuando quiero ejecutarla
desde el EXE que esta dentro de la carpeta Release no se comporta del todo
bien la aplicacion. Es como si se salteara pasos en la replicacion, cosas asi.
El sistema en si no es complejo, solo una clase que maneja la transferencia
de archivos por FTP y programacion MultiHilo, soportado sobre BD de Access,
es solo eso, nada complicado.
Como soy nuevo en el desarrollo de WinApp quiza me este faltando hacer algo,
asi que sera bienvenido cualquier comentario y/o ayuda
Gracias
 

Leer las respuestas

#1 José Escrich
09/02/2006 - 20:38 | Informe spam
Hernan,

Es probable que en modo Debug tus hilos se comporten de una forma y en Release
de otra, esto no es azaroso sino una cuestión de timing, habria que ver que
hacen exactamente esos hilos piensa y que ocurre si uno termina antes que
otro, en función de la lógica de tu aplicación.


José Escrich
jescrich (a) gmail.com
http://latincoder.com

HF> Hola, tengo una aplicacion hecha que gestiona trabajos de
HF> replicacion de
HF> archivos entre N servidores. El problema es que si yo compilo la
HF> solucion y
HF> me ejecuta el proyecto, todo funciona perfecto, pero cuando quiero
HF> ejecutarla
HF> desde el EXE que esta dentro de la carpeta Release no se comporta
HF> del todo
HF> bien la aplicacion. Es como si se salteara pasos en la replicacion,
HF> cosas asi.
HF> El sistema en si no es complejo, solo una clase que maneja la
HF> transferencia
HF> de archivos por FTP y programacion MultiHilo, soportado sobre BD de
HF> Access,
HF> es solo eso, nada complicado.
HF> Como soy nuevo en el desarrollo de WinApp quiza me este faltando
HF> hacer algo,
HF> asi que sera bienvenido cualquier comentario y/o ayuda
HF> Gracias

Preguntas similares