Forums Últimos mensajes - Powered by IBM
 

contar.si por codigo

23/06/2005 - 19:40 por Brel | Informe spam
Hola grupo,
intento usar varias funciones de excel por código en vez de asignarle
formula a una celda (rango de celdas) pero no lo consigo. Por ejemplo:
=SI(CONTAR.SI($B$6:B6;B6)-1=0;CONTAR.SI($B$6:$B$105;B6);"")
en b6:b102 (la mayoyia libres, o sea el rango es variable) hay fechas
de mas antigua a mas moderna y quiero contar cuantas veces se repiten
las fechas.
Gracias a todos -as.
Brel
 

Leer las respuestas

#1 KL
24/06/2005 - 01:14 | Informe spam
Hola Brel,

1) No encuentro mucho sentido en la formula que expones
2) [$B$6:B6;B6)-1=0] es igual a [$B$6:B6;B6)=1]
3) Recuerda que en VBA debes usar las funciones en ingles si usas la
propiedad Formula, FormulaR1C1, etc.. De lo contrario podrias usar
FormulaLocal o FomulaR1C1Local
4) Si quieres que al introducir la formula mediante codigo esa sea relativa,
o sea que los rangos se actualices segun la posicion de la celda, es mejor
usar la notacion R1C1. Tambien podrias usar la notacion normal, pero
introduciendo variables para los valores que cambian.
5) ?Por que no expones el macro que intyentas usar?

Saludos,
KL


3) Si quieres que
"Brel" wrote in message
news:
Hola grupo,
intento usar varias funciones de excel por código en vez de asignarle
formula a una celda (rango de celdas) pero no lo consigo. Por ejemplo:
=SI(CONTAR.SI($B$6:B6;B6)-1=0;CONTAR.SI($B$6:$B$105;B6);"")
en b6:b102 (la mayoyia libres, o sea el rango es variable) hay fechas
de mas antigua a mas moderna y quiero contar cuantas veces se repiten
las fechas.
Gracias a todos -as.
Brel

Preguntas similares