Forums Últimos mensajes - Powered by IBM
 

Convertir formula en su valor

22/03/2011 - 12:23 por Gusgus | Informe spam
Buenos días a todos,

A ver como planteo esto sin liarme demasiado: trabajo con excel 2003 y
en una celda tengo una fórmula que me cuenta los valores únicos de una
fila entera que está en otra hoja. La fórmula estaba bien pero no me
daba el resultado hasta que me he dado cuenta de que los números de la
fila de la otra hoja se obtienen también a través de una fórmula, ya
que se va rellenando según vamos metiendo datos en otras celdas; en el
momento que he sustituido manualmente esta fórmula por su valor
(copiar, pegado especial, valor), la fórmula de la celda inicial me ha
dado el resultado.

La cuestión es si es posible que en esa fila la fórmula se vaya
sustituyendo automáticamente por su valor (desapareciendo así la
fórmula) según se vayan rellenando los datos y que, a su vez, se
mantenga la fórmula en las celdas de esa fila que aún no tienen datos.

¿es rizar el rizo??? ¿es esto posible?

Muchas gracias por vuestro interés.

GusGus
 

Leer las respuestas

#1 Juan Español
22/03/2011 - 13:10 | Informe spam
Hola Gusgus:
Para dar de pleno con la respuesta tendrías que habernos indicado
con qué fórmula cuentas los registros únicos.
Pero de todas formas inténtalo con esta:

=SUMAPRODUCTO(--(FRECUENCIA(Hoja2!A1:A100;Hoja2!A1:A100)>0))

Suponiendo que los datos en los que quieres buscar registros
únicos estén en el rango:
Hoja2!A1:A100

La otra solución que propones, también es factible
con un poco de código y a través del evento
Worksheet_Change
Para decirte que solución es mejor, habría que ver el caso.

Saludos.-


"Gusgus" escribió en el mensaje de noticias
news:
Buenos días a todos,

A ver como planteo esto sin liarme demasiado: trabajo con excel 2003 y
en una celda tengo una fórmula que me cuenta los valores únicos de una
fila entera que está en otra hoja. La fórmula estaba bien pero no me
daba el resultado hasta que me he dado cuenta de que los números de la
fila de la otra hoja se obtienen también a través de una fórmula, ya
que se va rellenando según vamos metiendo datos en otras celdas; en el
momento que he sustituido manualmente esta fórmula por su valor
(copiar, pegado especial, valor), la fórmula de la celda inicial me ha
dado el resultado.

La cuestión es si es posible que en esa fila la fórmula se vaya
sustituyendo automáticamente por su valor (desapareciendo así la
fórmula) según se vayan rellenando los datos y que, a su vez, se
mantenga la fórmula en las celdas de esa fila que aún no tienen datos.

¿es rizar el rizo??? ¿es esto posible?

Muchas gracias por vuestro interés.

GusGus

Preguntas similares