Forums Últimos mensajes - Powered by IBM
 

DIAS LABORABLES ??

16/03/2010 - 23:54 por Orfao | Informe spam
Hola Grupo !
con respencto a la pregunta que formule con anterioridad
consegui una solucion
pero necesito ayuda para poder adaptarla a intervalos de periodos mas largos

la formula en cuestion es la siguiente:

=+SI($AB$7<8;EXTRAE(SI(DIAS.LAB(AF7+1;AF7+1;feriados);DESREF($GR$25;DIASEM(AF7;2)+1;0;1;1);"
")&SI(DIAS.LAB(AF7+2;AF7+2;feriados);DESREF($GR$25;DIASEM(AF7;2)+2;0;1;1);"
")&SI(DIAS.LAB(AF7+3;AF7+3;feriados);DESREF($GR$25;DIASEM(AF7;2)+3;0;1;1);"
")&SI(DIAS.LAB(AF7+4;AF7+4;feriados);DESREF($GR$25;DIASEM(AF7;2)+4;0;1;1);"
")&SI(DIAS.LAB(AF7+5;AF7+5;feriados);DESREF($GR$25;DIASEM(AF7;2)+5;0;1;1);"
")&SI(DIAS.LAB(AF7+6;AF7+6;feriados);DESREF($GR$25;DIASEM(AF7;2)+6;0;1;1);"
")&SI(DIAS.LAB(AF7+7;AF7+7;feriados);DESREF($GR$25;DIASEM(AF7;2)+7;0;1;1);"
");1;$AB$7);"")

RESULTADO ="JV L X"

INDICA SOLO SE TRABAJA Jue,Vie,Lun Y Mie

SABADO Y DOMINGO FERIADOS Y EL MARTES 23/3 FERIADO

AB7=7 (DIAS DE INTERVALO POR PERIODO)
AF7/03/10 (FECHA FIN PERIODO ANTERIOR)



GS1:GS6=feriados
G1/04/10
G2/04/10
G3/04/10
G5#/03/10
G6= (VACIO)
GR25=(VACIO)
GR26 y GR32="L"
GR27 y GR33="M"
GR27 y GR34="X"
GR28 y GR35="J"
GR29 y GR36="V"
GR30 y GR37="S"
GR31 y GR38="D"


Podría mejorarse para periodos mas largos ej: 15 o 30 días sin tener que
estar concatenando ?
Tal vez diseñando la formula en forma matricial ??


Gracias
Me alimento del conocimiento de todos
 

Leer las respuestas

#1 Héctor Miguel
18/03/2010 - 07:38 | Informe spam
hola, moises !

... necesito ayuda para poder adaptarla a intervalos de periodos mas largos
la formula en cuestion es la siguiente: (...)



la logica indica que mientras necesites rescatar varios valores de una
coleccion
(en vez de rescatar uno solo de los valores en esa coleccion)...
no escaparas de la necesidad de alguna forma de concatenacion (?)

(probablemente) podrias conseguir una formula que devuelva una matriz
(pero...)
despues tendrias que rescatar por indices cada uno de los valores en la
matriz :-((

saludos,
hector.

Preguntas similares