Forums Últimos mensajes - Powered by IBM
 

Diferencia de fechas

02/09/2005 - 11:30 por anonimo | Informe spam
En Excel xp español, aplicando esta fórmula TEXTO(B1-A1;"dd-mm-aa"), se
obtiene el número de días, meses y años entre dos fechas, sin embargo, el
número de meses es incorrecto (siempre dice uno más de lo correcto).
¿Alguien puede aportar información al respecto?

Gracias
 

Leer las respuestas

#1 KL
02/09/2005 - 11:59 | Informe spam
Hola anonimo,

"anonimo" wrote in message
news:
En Excel xp español, aplicando esta fórmula TEXTO(B1-A1;"dd-mm-aa"), se
obtiene el número de días, meses y años entre dos fechas



En primer lugar, la afirmacion de arriba es incorrecta :-( Lo que devuelve
la formula es la fecha que corresponde al valor que resulta de la resta de
B1-A1. Partiendo de que las fechas en Excel se expresan atraves del numero
de dias transcurridos desde 01-01-1900 (valor 0),

si

[A1]7987-01-2004
[B1]87171-12-2005

entonces la resta devolvera
7300-12-1901

Por lo tanto, es recomendable usar la funcion SIFECHA:

=TEXTO(SIFECHA(A1;B1;"Md");"00")&TEXTO(SIFECHA(A1;B1;"Ym");"-00")&TEXTO(SIFECHA(A1;B1;"Y");"-00")

Saludos,
KL

Preguntas similares