Forums Últimos mensajes - Powered by IBM
 

Diseño de gráfico

07/10/2009 - 12:57 por Conrrad | Informe spam
Estimados amigos, os explico:

Doce celdas que representan los meses de enero a diciembre, en ellas
hay fórmulas que leen de una tabla.

Los datos calculados, actualmente, los tengo hasta septiembre, por lo
que las celdas de octubre, noviembre y diciembre, aún llevando
fórmula, aparecen en blanco ya que en la fórmula tengo especificado
que si no hay valor ponga "".

Ahora tengo un grafico de líneas que lee de esos valores, 12 meses,
pero cuando llega al mes de octubre, donde no hay datos, el valor del
gráfico cae en picado hasta 0 lo mismo que con noviembre y diciembre.

Si borro las formulas de esos tres meses, el gráfico lo hace correcto,
pues se queda en el valor del último mes con datos, que es como quiero
que salga, pero no es la solución, pues me toca, para el resto de
meses, volver a escribir la fórmula cuando haya datos.

¿Se os ocurre alguna idea para que funcione como yo quiero?

Gracias
 

Leer las respuestas

#1 Gustavo Marinoni
07/10/2009 - 15:24 | Informe spam
Hola Conrrad,

el problema es que si devuelves "" Excel no considera como que la celda este
vacía sino que realmente tiene un string "" sin nada. Una posible solución
sería :

=SI(A1=0,ND(),A1). La formula ND() devuelve el valor de error #N/A que no
sera interpretado como 0.

Espero te sirva.

Saludos,
Gustavo
http://masexcel.blogspot.com
¡Importante!: Colabora con el grupo.Contesta a este mensaje
y dinos si te sirvió o no la respuesta dada. Muchas gracias.




"Conrrad" wrote:

Estimados amigos, os explico:

Doce celdas que representan los meses de enero a diciembre, en ellas
hay fórmulas que leen de una tabla.

Los datos calculados, actualmente, los tengo hasta septiembre, por lo
que las celdas de octubre, noviembre y diciembre, aún llevando
fórmula, aparecen en blanco ya que en la fórmula tengo especificado
que si no hay valor ponga "".

Ahora tengo un grafico de líneas que lee de esos valores, 12 meses,
pero cuando llega al mes de octubre, donde no hay datos, el valor del
gráfico cae en picado hasta 0 lo mismo que con noviembre y diciembre.

Si borro las formulas de esos tres meses, el gráfico lo hace correcto,
pues se queda en el valor del último mes con datos, que es como quiero
que salga, pero no es la solución, pues me toca, para el resto de
meses, volver a escribir la fórmula cuando haya datos.

¿Se os ocurre alguna idea para que funcione como yo quiero?

Gracias

Preguntas similares