Forums Últimos mensajes - Powered by IBM
 

ERROR EN FORMULA PROMEDIO

16/02/2005 - 16:31 por GSCSAL | Informe spam
SE PRODUCE UN ERROR EN LA FUNCION PROMEDIO QUE NO CONSIGO EXPLICAR:

SI ESCRIBIMOS EN EL RANGO B3:B7 LOS SIGUIENTES DATOS (SIN LAS COMILLAS):
"0,2" "0,2" "0,2" "-0,3" "-0,3"

LUEGO EN OTRA CELDA ESCRIBIMOS LA FUNCIÓN
=PROMEDIO(B3:B7)

SE SUPONE QUE EL RESULTADO DEBERÍA SER CERO, PERO EL RESULTADO QUE APARECE
ES: 2,22045E-17

ALGUNO PODRÍA DECIRME A QUÉ SE DEBE EL ERROR?
 

Leer las respuestas

#1 Daniel
16/02/2005 - 16:45 | Informe spam
supongo que el error de debe al algoritmo que usa excel para hacer el
promedio, pero si querés que te de cero poné =redondear(promedio(B3:b7)3), y
se te soluciona el problema (puse 3 decimales pero con cualquier número
menor que 15 debe andar bien)
de todos modos, a los efectos prácticos 2,2 E-17 es lo mismo que cero.

Daniel

"GSCSAL" escribió en el mensaje
news:
SE PRODUCE UN ERROR EN LA FUNCION PROMEDIO QUE NO CONSIGO EXPLICAR:

SI ESCRIBIMOS EN EL RANGO B3:B7 LOS SIGUIENTES DATOS (SIN LAS COMILLAS):
"0,2" "0,2" "0,2" "-0,3" "-0,3"

LUEGO EN OTRA CELDA ESCRIBIMOS LA FUNCIÓN
=PROMEDIO(B3:B7)

SE SUPONE QUE EL RESULTADO DEBERÍA SER CERO, PERO EL RESULTADO QUE APARECE
ES: 2,22045E-17

ALGUNO PODRÍA DECIRME A QUÉ SE DEBE EL ERROR?


Preguntas similares