Forums Últimos mensajes - Powered by IBM
 

Error Suma Producto

10/05/2005 - 21:04 por Angelo Vernaza | Informe spam
Buenas Tardes gente,

Estoy tratando de usar esta formula pero no c porke me da error:, todavia no
estoy muy practico con esta formula de SumaProducto:

=SUMAPRODUCTO(('400'!V$7:V$102)*('400'!B$7:B$102=--SUSTITUIR($a8,"-",""))*('
400'!Z$7:Z$102={G1;G2;G3;G4}))

donde:

'400'!V$7:V$102 =Al rango q quiero sumar
'400'!B$7:B$102 = Primera columna q quiero condicionar con este
valor: =--SUSTITUIR($A8,"-","")
'400'!Z$7:Z$102 = Segunda columna q quiero condicionar con estos
valoresL: ={G1;G2;G3;G4}

Espero q me puedan ayudar.

Saludos,
 

Leer las respuestas

#1 KL
10/05/2005 - 22:46 | Informe spam
Hola Angelo,

Si todavia te interesa el por que del error que te daba la formula inicial,
te comento. Es que las matrices solo pueden contener valores y no
referencias a objetos, ni objetos mismos. Es decir {G1;G2;G3;G4} no vale. Lo
podias haber hecho es esto: INDIRECTO({"G1";"G2";"G3";"G4"}), pero habrias
perdido la ventaja de la relatividad de las referencias, porque la expresion
anterior equivale a $G$1:$G$4, mientras que tu usas G$1:G$4.

Lo que si podrias hacer para reducir la formula es en vez de usar una matriz
fija, usar la matriz del rango G$1:G$4 previamente convertida en horizontal
mediante la funcion TRANSPONER, es decir:
=SUMAPRODUCTO(('400'!V$7:V$102)*('400'!B$7:B$102=--SUSTITUIR($a8,"-",""))*('400'!Z$7:Z$102=TRANSPONER(G$1:G$4)))

Saludos,
KL


"Angelo Vernaza" wrote in message
news:
Ya lo solucioné con esta formula:

=SUMAPRODUCTO(('400'!V$7:V$102)*('400'!B$7:B$102=--SUSTITUIR($A12,"-",""))*(
('400'!Z$7:Z$102=G$1)+('400'!Z$7:Z$102=G$2)+('400'!Z$7:Z$102=G$3)+('400'!Z$7
:Z$102=G$4)))


"Angelo Vernaza" escribió en el
mensaje news:#
Buenas Tardes gente,

Estoy tratando de usar esta formula pero no c porke me da error:, todavia


no
estoy muy practico con esta formula de SumaProducto:




=SUMAPRODUCTO(('400'!V$7:V$102)*('400'!B$7:B$102=--SUSTITUIR($a8,"-",""))*('
400'!Z$7:Z$102={G1;G2;G3;G4}))

donde:

'400'!V$7:V$102 =Al rango q quiero sumar
'400'!B$7:B$102 = Primera columna q quiero condicionar con este
valor: =--SUSTITUIR($A8,"-","")
'400'!Z$7:Z$102 = Segunda columna q quiero condicionar con estos
valoresL: ={G1;G2;G3;G4}

Espero q me puedan ayudar.

Saludos,






Preguntas similares