Forums Últimos mensajes - Powered by IBM
 
Tags Palabras claves

Fijar fecha

27/09/2008 - 16:44 por Julián | Informe spam
En el día de ayer decidí probar con la solución aportada por Héctor Miguel,
porque significaría un avance en mis libros de cálculo. Sin embargo, me
encuentro con que el resultado es contrario a la explicación dada por Héctor,
en mi caso es igual que si hubiera utilizado HOY() o ahora(). Esto me hace
pensar que algo estoy haciendo mal, aunque no se lo que es.
Tengo Excel 2007. Hice lo siguiente:
1. Abrí un nuevo libro en el que en las celdas A1:A10 puse la función
indicada por Héctor, es decir: =SI(B4<>"";miFecha(B4))
2. Inserté un módulo general denominado miFecha, con el código copiado de la
respuesta de Héctor:
Function miFecha(Celda As Range) As Date
Volatile = False
miFecha = Now
End Function
3. En el libro de Excel tengo:

27/09/2008 12544
27/09/2008 2563
27/09/2008 1256
27/09/2008 456
FALSO
FALSO
4. La fecha que indicaba el libro, en el día de ayer, era el 26/09/2008 y
sin embargo hoy esa fecha está actualizada a la fecha del día, por lo que
supongo que mañana indicará la fecha de mañana y cada día la que corresponda.
¿Qué es lo que hago mal?

Saludos,
Julián.
 

Leer las respuestas

#1 Ivan
27/09/2008 - 23:04 | Informe spam
hola Julian,

mientras llega Hector, solo un par de apuntes:

a) comentarte que a mi me funciona perfectamente, es decir solo se
actualiza la fecha cuando se modifica el valor de las celdas-condicion

b) para asegurarte mejor en las pruebas dale un formato que incluya
los minutos y los segundos, Asi veras el cambio en cada instante y no
tendras que esperar al dia siguiente ara comprobarlo.

c) ¿no tendras formulas en dichas celdas que se recalculen
automaticamente y que cambien el contenido de dichas celdas al abrir
el libro o similar?

d) prueba a poner algo tipo a esto =SI(B8="";"";AHORA()) junto a la
funcion de Hector, Creo que notaras la diferencia


bueno, lo dicho, para que pruebes en tanto te dan otra respuesta

un saludo
Ivan

Preguntas similares