Forums Últimos mensajes - Powered by IBM
 
Tags Palabras claves

Formula que no va

24/04/2006 - 19:36 por Bolindre | Informe spam
alguien sabria por que no funciona esta formula gracias
=SI($A22<>Materiales!B3:B22;CONCATENAR(Materiales!C7:C22);"")
La idea es extraer un texto con una condicion dada un una lista de codigos
Bolindre
 

Leer las respuestas

#1 Héctor Miguel
24/04/2006 - 21:22 | Informe spam
hola, anonimo/a' !

alguien sabria por que no funciona esta formula gracias
=SI($A22<>Materiales!B3:B22;CONCATENAR(Materiales!C7:C22);"")
La idea es extraer un texto con una condicion dada un una lista de codigos



1) con respecto de la primera parte de tu formula: -> SI($A22<>Materiales!B3:B22
a) si estas 'comparando' textos -?- necesitas modificar a algo +/- como lo siguiente:
=si(contar.si(materiales!b3:b22;$a22)=0
b) si estas 'comparando' valores -?- necesitas modificar a algo +/- como lo siguiente:
=si($a22<>suma(materiales!b3:b22)

2) con respecto de la segunda parte de tu formula: -> CONCATENAR(Materiales!C7:C22)
la funcion 'concatenar' SOLO va a 'concatenar' los valores INDIVIDUALES que le indiques :-(
[es decir] tendrias que utilizar +/-: -> concatenar(materiales!c2;materiales!c3;materiales!c4;<...>materiales!c22)
o... definir una funcion personalizada que se encargue de 'unir' el contenido del rango que le solicites :))

si cualquier duda [o informacion adicional]... comentas ?
saludos,
hector.

Preguntas similares