Forums Últimos mensajes - Powered by IBM
 
Tags Palabras claves

formulas

18/01/2005 - 02:19 por Alexander | Informe spam
estoy tratando que al calcular el tiemp me lo con vierta en pesos la formula
que estoy tratando de hacer es esta:
=SI(D13="";"";SI(F13<=0;"";SI(F13< ;"600";SI(F13<5;"900";SI(F13<P;"1100";SI(F13<e;"1300";SI(F13<€;"1900";SI(F13<•;"2200";)))))))),solo
llego a los 95 minutos despues no me valida
la idea:
1. No se si esta formula esta bien, pero si es asi quisiera proteger la
celda sin que me proteja la hoja de tal manera que no se me borre
 

Leer las respuestas

#1 Héctor Miguel
18/01/2005 - 05:03 | Informe spam
hola, Alexander !

estoy tratando que al calcular el tiempo me lo con vierta en pesos
la formula que estoy tratando de hacer es esta [...]
... solo llego a los 95 minutos despues no me valida
la idea:
1. No se si esta formula esta bien [...]
... quisiera proteger la celda sin que me proteja la hoja de tal manera que no se me borre



la formula esta bien... 'el problema' es que NO se pueden 'anidar' mas de siete funciones en las formulas :(

1.- prueba con la siguiente formula... [analizala y modifica/agrega/etc. segun consideres necesario]...
=si(o(d13="";f13<=0);"";indice({6;9;11;13;19;22;25;28;30};coincidir(f13;{1;21;36;51;66;81;96;111;126}))*100)

=> probablemente deberas encontrar el caracter 'separador' de argumentos de 'matrices constantes' [entre llaves]
en 'mi' sistema 'funciona' el punto y coma y la diagonal invertida [pudiera ser '@' o cualquier otro]

2.- para proteger 'la/s celdas' SIN proteger la hoja [o el libro]...
a) podrias usar codigo en el evento '_change' del modulo de 'esa' hoja, 'detectar' si se borran la/s celda/s 'especial/es'
[etc. etc. etc.]... creo que resultaria [mas bien] en un 'embrollo'
b) puedes 'almacenar' la formula ->en un nombre 'definido' por el usuario<- p.ej.
[menu] insertar / nombres / definir...
nombre: el nombre que prefieras
'se refiere a:' -> aqui 'pones' tu la formula
de esta manera, puedes 'llamar' [simplemente] 'al nombre' ->en la celda<- donde requieras 'el calculo' ;)
=> toma nota de que en las formulas 'almacenadas' en nombres... 'juegan' las referencias 'absolutas/relativas'

si cualquier duda... ¿comentas?
saludos,
hector.

Preguntas similares