Forums Últimos mensajes - Powered by IBM
 

Formulas matriciales

22/12/2005 - 20:11 por Gabriel Raigosa | Informe spam
Saludos;

En esta pagina web
www..X-Cell\xcell05.free.fr/index.html

encontre lo siguiente;

1) Simplifier les formules matricielles par la fonction SOMMEPROD
La fonction SOMMEPROD sert en principe à calculer une somme de produits :

=SOMMEPROD(A1:A3;B1:B3) renvoie A1*B1+A2*B2+A3*B3

Une caractéristique (non documentée par Microsoft) de SOMMEPROD est
qu'elle marche comme fonction matricielle sans nécessiter une saisie
matricielle par Ctrl+Maj+Entrée. Ainsi :

{=SOMME(N(A1:A10)<100))} (validé par Ctrl+Maj+Entrée) a pour équivalent :

=SOMMEPROD(N(A1:A10)<100) (validé simplement par Entrée)

Il est à noter que cette particularité n'implique aucune différence en
termes de vitesse de calcul.

Par commodité, la fonction SOMMEPROD est utilisée dans le reste de cet
article dans toutes les formules où elle est substituable à {=SOMME(...)}


Que hace la "N", que hay en esta funcion {=Suma(N(A1:A10)<100))}, pongo
esta función y me da uno,

Y por otro lado la función =SumaProducto(N(A1:A10)<100)) , que segun dice
solo se valida con enter tampoco hace nada me da #¡valor!

"N" ,Devuelve un valor convertido en un número, Sintaxis N(valor)

tks
Gabriel Raigosa
Medellín - Colombia
GabrielRaigosa@hot.mail.com
 

Leer las respuestas

#1 KL
22/12/2005 - 21:36 | Informe spam
Hola Gabriel,

Que hace la "N", que hay en esta funcion {=Suma(N(A1:A10)<100))}...



Enhorabuena! Tienes buena vista eh! Para empezar, he comprobado personalmente y parece que al maestro Laurent Longre le sobra un
parentesis en la formula :-) Creo que deberia ser asi:

=SUMA(N(A1:A10<100))

Para entender lo que hace prueba introducir en cualquier celda las siguientes formulas:

=N(VERDADERO)
=N(FALSO)

es lo que hace - forzar la conversion de los valores logicos VERDADERO y FALSO en sus equivalentes numericos 1 y 0. La mayoria de la
gente usa los dos menoses

=--VERDADERO
=--FALSO

pero tambien se puede hacerlo mediante cualquier operacion aritmentica basica (*,/,^,-,+) o mediante la funcion VALOR()

Esta conversion es necesaria porque la equacion [A1:A10<100] devuelve una matriz compuesta por 10 valores logicos, algo asi:

{VERDADERO\FALSO\VERDADERO\FALSO...}

que no puede sumarse mediante funcion a no ser que se convierta en valor numerico.

...pongo esta función y me da uno,



Si ahora vuelves a introducir la formula con mi correccion y usando las teclas Ctrl+Shift+Enter te devolvera el numero de valores
superiores a 0 en el rango evaluado:

=SUMA(N(A1:A10<100))

Y por otro lado la función =SumaProducto(N(A1:A10)<100)) , que segun dice solo se valida con enter tampoco hace nada me da
#¡valor!



...y aqui basta con introducir la formula de m,anera habitual (Enter):

=SUMAPRODUCTO(N(A1:A10<100))

Saludos,
KL

Preguntas similares