Forums Últimos mensajes - Powered by IBM
 

impresion y terminal server

03/05/2006 - 09:16 por arb2000 | Informe spam
Buenas tardes, os comento mi caso, que me está trayendo loco ...

Se trata de imprimir desde PDA (Pocket PC), bajo una sesión de
Terminal Server, con una aplicación instalada en un (único) servidor,
en una impresora instalada en otra máquina.

El sistema operativo servidor es Windows 2003 server Standard Edition.
Las estaciones de trabajo Windows XP Professional SP2, y las Pocket PC,
Windows Mobile 2003. La organización tiene el Directorio Activo
levantado y bien configurado, o eso creo.

La aplicación está instalada en el servidor, y las diferentes
estaciones de trabajo, tienen sus correspondientes impresoras (en
función de las necesidades, matriciales, tickets, láser). Todas ellas
acceden a la aplicación de servidor, mediante el mapeo de su
correspondiente unidad de red. Hasta aquí, todo funciona
correctamente.

Después de haber intentado definir la situación correctamente, os lo
explico mas "llanamente". Un restaurante. Tiene un servidor con el
programa, y diferentes estaciones de trabajo para comedores, oficinas,
etc... Todo va bien, hasta que aparecen 2 Pocket PC para la terraza.

Con la correcta configuración del programa propietario (mismo usuario,
empresa y caja - correspondientes al propio programa propietario)
funciona e imprime correctamente desde el PC que tiene conectada
físicamente la impresora. Sin embargo desde la PDA, en la sesión de
Terminal Server, accedo a la aplicación y esta funciona correctamente,
pero no consigo imprimir los famosos tickets.

La impresora está instalada localmente en el PC que físicamente mas
cerca está de la terraza (además dicha impresora funciona
correctamente desde dicho equipo). Compartida con un nombre menor de 8
caracteres.

Desde las PDA, primero establezco la sesión de Terminal Server, e
inicio la aplicación. Para capturar el puerto de la impresora, intento
realizarla de la siguiente manera, aunque no funciona.

net use lpt1 \\máquinaecursocompartido usuario:contraseña
/persistent:yes
net use lpt1 \\delicat\tickets admin:1234 admin:1234 /persistent:yes

Y a partir de aquí comienzan los problemas. Tras diversas pruebas y
sin saber muy bien cómo ;-( he conseguido imprimir a través de dicha
PDA, ... un dir>lpt2. Pero no consigo nada mas.

En una de tantas pruebas, desde otra estación de trabajo, he intentado
realizar el comando net use, pero tras ingresar usuario y contraseña
(correctos), obtengo Error de Sistema nº5.

En este punto, y tras haber buscado en foros y diversa documentación,
creo que tengo "sobredosis de información", osease que estoy atascado.


No sé si debo utilizar el comando net use, o revisar la configuración
de Terminal Server, así que realmente no sé si el problema es de
captura de puerto, o directamente de controladores o impresora.

Os agradecería me echaseis una mano, ya que la situación aunque no
parece tan complicada, no veo manera de sacarla.

Muchas gracias y un saludo de antemano.
 

Leer las respuestas

#1 Javier Inglés [MS MVP]
03/05/2006 - 11:33 | Informe spam
Has probado a capturar la impresora directamente en la sesión de terminal
server para ver si así funciona?? Es decir, en vez de mapear la impresora
durante la conexión vía RDP, una vez conectada la sesión, mapear desde ahí
la impresora y probar

Salu2!!
Javier Inglés
https://mvp.support.microsoft.com/p...B5567431B0
MS MVP, Windows Server-Directory Services




"arb2000" escribió en el mensaje
news:
Buenas tardes, os comento mi caso, que me está trayendo loco ...

Se trata de imprimir desde PDA (Pocket PC), bajo una sesión de
Terminal Server, con una aplicación instalada en un (único) servidor,
en una impresora instalada en otra máquina.

El sistema operativo servidor es Windows 2003 server Standard Edition.
Las estaciones de trabajo Windows XP Professional SP2, y las Pocket PC,
Windows Mobile 2003. La organización tiene el Directorio Activo
levantado y bien configurado, o eso creo.

La aplicación está instalada en el servidor, y las diferentes
estaciones de trabajo, tienen sus correspondientes impresoras (en
función de las necesidades, matriciales, tickets, láser). Todas ellas
acceden a la aplicación de servidor, mediante el mapeo de su
correspondiente unidad de red. Hasta aquí, todo funciona
correctamente.

Después de haber intentado definir la situación correctamente, os lo
explico mas "llanamente". Un restaurante. Tiene un servidor con el
programa, y diferentes estaciones de trabajo para comedores, oficinas,
etc... Todo va bien, hasta que aparecen 2 Pocket PC para la terraza.

Con la correcta configuración del programa propietario (mismo usuario,
empresa y caja - correspondientes al propio programa propietario)
funciona e imprime correctamente desde el PC que tiene conectada
físicamente la impresora. Sin embargo desde la PDA, en la sesión de
Terminal Server, accedo a la aplicación y esta funciona correctamente,
pero no consigo imprimir los famosos tickets.

La impresora está instalada localmente en el PC que físicamente mas
cerca está de la terraza (además dicha impresora funciona
correctamente desde dicho equipo). Compartida con un nombre menor de 8
caracteres.

Desde las PDA, primero establezco la sesión de Terminal Server, e
inicio la aplicación. Para capturar el puerto de la impresora, intento
realizarla de la siguiente manera, aunque no funciona.

net use lpt1 \\máquinaecursocompartido usuario:contraseña
/persistent:yes
net use lpt1 \\delicat\tickets admin:1234 admin:1234 /persistent:yes

Y a partir de aquí comienzan los problemas. Tras diversas pruebas y
sin saber muy bien cómo ;-( he conseguido imprimir a través de dicha
PDA, ... un dir>lpt2. Pero no consigo nada mas.

En una de tantas pruebas, desde otra estación de trabajo, he intentado
realizar el comando net use, pero tras ingresar usuario y contraseña
(correctos), obtengo Error de Sistema nº5.

En este punto, y tras haber buscado en foros y diversa documentación,
creo que tengo "sobredosis de información", osease que estoy atascado.


No sé si debo utilizar el comando net use, o revisar la configuración
de Terminal Server, así que realmente no sé si el problema es de
captura de puerto, o directamente de controladores o impresora.

Os agradecería me echaseis una mano, ya que la situación aunque no
parece tan complicada, no veo manera de sacarla.

Muchas gracias y un saludo de antemano.

Preguntas similares