Forums Últimos mensajes - Powered by IBM
 

MEJORAR CON SUMAR.SI

02/08/2005 - 17:43 por Hernando | Informe spam
Hola a todos.

No consigo solucionar lo siguiente:

A1:A25 F1:F25
A 750
A 1250
B 300
C 4500
D 875
B 1400
G 1860
G 750
B 650
A... etc, y en la columna L1:L8 tengo las celdas
correspondientes "A", "B","C", "D", "E","F","G" y "H"
poniendo =SUMAR.SI($A$1:$A$25;"A";$F$1:$F$25), en cada una de ellas
consigo que me sume las A,B,C,D de A1:A25, con los valores que
tienen en F1:F25 correctamente.

He incorporado una columna más B1:B25 donde pongo otra clave de dos
letras ab, ac, ad, ae, afy otra columna con valores para esas
claves L1:L25

Necesito que en las celdas para "A","B","C","D" formula que me de la
suma de los valores de: ab,ac,ad,ae,de cada una de las A,B,C,D,
etc.

Resumiendo que contando con A,B,C,D, y con ab,c,ad,ae.me de la suma
de los valores de las segundas pero agrupados por las A,B,C,D.

Espero haberme explicado, gracias y saludos.
 

Leer las respuestas

#1 KL
02/08/2005 - 18:46 | Informe spam
Hola Hernando,

Dos posibilidades:

1) Tabla dinamica.

2) La funcion SUMAPRODUCTO

a. Mueve los valores "A", "B","C", "D", "E","F","G" y "H" del rango [L1:L8]
al [L2:L9] (una fila mas abajo)
b. En las celdas [M1:P1] pon "ab","ac","ad" y "ae" respectivamente
c. En la celda [M2] introduce la siguiente formula y copiala hacia abajo y
hacia la derecha:
=SUMAPRODUCTO(($A$1:$A$25)=$L2)*($B$1:$B$25=M$1)*$F$1:$F$25)

Regards,
KL



"Hernando" wrote in message
news:
Hola a todos.

No consigo solucionar lo siguiente:

A1:A25 F1:F25
A 750
A 1250
B 300
C 4500
D 875
B 1400
G 1860
G 750
B 650
A... etc, y en la columna L1:L8 tengo las celdas
correspondientes "A", "B","C", "D", "E","F","G" y "H"
poniendo =SUMAR.SI($A$1:$A$25;"A";$F$1:$F$25), en cada una de ellas
consigo que me sume las A,B,C,D de A1:A25, con los valores que tienen
en F1:F25 correctamente.

He incorporado una columna más B1:B25 donde pongo otra clave de dos letras
ab, ac, ad, ae, afy otra columna con valores para esas claves
L1:L25

Necesito que en las celdas para "A","B","C","D" formula que me de la suma
de los valores de: ab,ac,ad,ae,de cada una de las A,B,C,D, etc.

Resumiendo que contando con A,B,C,D, y con ab,c,ad,ae.me de la suma de
los valores de las segundas pero agrupados por las A,B,C,D.

Espero haberme explicado, gracias y saludos.

Preguntas similares