Microsoft Graph. Problema entre versiones 2000 y XP con "pegar vínculos" L1C1 y F1C1.

15/02/2007 - 12:07 por L. Garcia | Informe spam
Hola a todos.

Primero decir que pregunto en varios grupos que creo que me podreis ayudar,
ya que no he encontrado un grupo de Microsoft Graph :-)

El problema es:

Tengo ficheros PPT, con graficos Microsoft Graph, y los datos han sido
pegados mediante "Pegar Vinculos" de unas tablas de Excel, todo ello con la
version del Office2000 SP3.

Si estos ficheros PPT, los abro con Office 2003 SP2 (en otro ordenador), e
intento 'Actualizar Vinculos' me da error de que no se encuentra el
elemento. Compruebo que todo esta correcto y me doy cuenta de una cosa:

En 'elemento', donde se indica el rango de Excel donde están los datos, en
la version Office2000, usa la notacion L1C1 (version en castellano de R1C1),
en cambio en Office2003, usa la notacion F1C1 (¿version en castellano para
Office2003?)

Si cambio a mano la referencia en 'elemento' y cambio la 'L' por la 'F',
entonces el vinculo funciona correctamente.


Para reproducir el problema en Office2000 SP3 (WorkAround)



1) Crear un nuevo fichero XLS.
2) Crear una tabla de datos, por ejemplo:
Col1 Col2 Col3 Col4
Prd1 1 2 3 4
Prd2 2 3 4 1
Prd3 3 4 1 2

3) Guardar el fichero.

4) Abrir un nuevo PPT, y crear una nueva diapositiva
5) Insertar un nuevo grafico...

6) Cambiar al fichero XLS y seleccionar la tabla de datos. Copiar datos.

7) Cambiar al fichero PPT. Seleccionar la hoja de datos del grafico.
8) Menu "Edicion | Pegar Vinculos..." Pulsar Aceptar a la pregunta.

9) En estos momentos tengo el grafico vinculado a los datos de EXCEL, pero
si
consulto en el menu "Edicion | Vinculos", en elemento me pone la referencia
en notacion L1C1.


Para reproducir el problema en Office2003 SP2 (WorkAround)



1) Exactamente lo mismo ;-), solo que en el paso 9), en elemento me pone la
referencia en notacion F1C1, y es lo que me causa los problemas.

NOTA IMPORTANTE: En el grupo de ".es.excel" ya me han ayudado a llegar a
'localizar' el problema, y Hector Miguel a tenido la gentileza de probar los
pasos anteriores, pero al tener Office2000 y 2003 en la misma maquina, el
problema no se reproduce, puesto que la version de Microsoft Graph es la
misma (o no, pero quizas comparte la configuracion local) para ambos Office.

PREGUNTA:

¿ Como cambio la configuracion de Microsoft Graph para que me reconozco L1C1
?

Porque cambiar los 'tropecientos' PPTs con sus correspondientes 'cienes y
cienes' de vinculos no es plan :-), aparte de que los usuarios seguiran
durante una temporada trabajando unos con Off2000 y otros con Off2003.

Saludos y gracias por anticipado.
 

Leer las respuestas

#1 Enric Mañas [MS MVP Office-PowerPoint]
15/02/2007 - 23:28 | Informe spam
L. Garcia,

...mal asunto...

...ni uso ni *conozco* Excel y no voy a poder ayudarte *demasiado*... Te
apunto unas *ideas*... Coméntanos...

en cambio en Office2003, usa la notacion F1C1 (¿version en castellano para Office2003?)



En Herramientas > Opciones | General | en Configuración hay un Estilo de
referencia F1C1

pero al tener Office2000 y 2003 en la misma maquina, el problema no se reproduce, puesto que la version de Microsoft Graph es la misma (o no, pero quizas comparte la configuracion local) para ambos Office.



1. La versión de MS Graph se “corresponde” con la versión de Office que
tengas instalada...

Para Office 2000 es MS Graph 9
Para Office 2002 es MS Graph 10
Para Office 2003 es MS Graph 11

(lo puedes ver en la "Ayuda" (?) de MS Graph (Acerca de Microsft Graph))

y SÓLO puedes tener *una* versión de MS Graph instalada...

y *siempre* la última versión que instales eliminará las anteriores...

2. Excel 2002 tiene en Herramientas > Opciones | General | Configuración:
Estilo de referencia L1C1

Con todo esto... Qué haría *yo* si tuviera ese problema...

Lo probaría en ordenadores diferentes o en máquinas virtuales...
http://www.microsoft.com/latam/wind...virtualpc/

Instalaría por orden de antigüedad y en diferentes carpetas cada una de las
versiones de Office... y actualizaría al máximo cada una de las versiones
ANTES de instalar la siguiente...

No instalaría la versión posterior de MS Graph hasta haber comprobado que
realmente el funcionamiento no se modifica...

Por si te sirve...

Creando una nueva presentación con PowerPoint 2000 y MS Graph 9 (el
correspondiente a 2000) con vínculos a un Excel 2002 (con el estilo L1C1
activado)... se actualiza sin problemas en un sistema con PowerPoint y Excel
y MS Graph 2003...

Cordialmente

Enric
Enric Mañas [MS MVP Office-PowerPoint]


"L. Garcia" escribió:

Hola a todos.

Primero decir que pregunto en varios grupos que creo que me podreis ayudar,
ya que no he encontrado un grupo de Microsoft Graph :-)

El problema es:

Tengo ficheros PPT, con graficos Microsoft Graph, y los datos han sido
pegados mediante "Pegar Vinculos" de unas tablas de Excel, todo ello con la
version del Office2000 SP3.

Si estos ficheros PPT, los abro con Office 2003 SP2 (en otro ordenador), e
intento 'Actualizar Vinculos' me da error de que no se encuentra el
elemento. Compruebo que todo esta correcto y me doy cuenta de una cosa:

En 'elemento', donde se indica el rango de Excel donde están los datos, en
la version Office2000, usa la notacion L1C1 (version en castellano de R1C1),
en cambio en Office2003, usa la notacion F1C1 (¿version en castellano para
Office2003?)

Si cambio a mano la referencia en 'elemento' y cambio la 'L' por la 'F',
entonces el vinculo funciona correctamente.

> Para reproducir el problema en Office2000 SP3 (WorkAround)

1) Crear un nuevo fichero XLS.
2) Crear una tabla de datos, por ejemplo:
Col1 Col2 Col3 Col4
Prd1 1 2 3 4
Prd2 2 3 4 1
Prd3 3 4 1 2

3) Guardar el fichero.

4) Abrir un nuevo PPT, y crear una nueva diapositiva
5) Insertar un nuevo grafico...

6) Cambiar al fichero XLS y seleccionar la tabla de datos. Copiar datos.

7) Cambiar al fichero PPT. Seleccionar la hoja de datos del grafico.
8) Menu "Edicion | Pegar Vinculos..." Pulsar Aceptar a la pregunta.

9) En estos momentos tengo el grafico vinculado a los datos de EXCEL, pero
si
consulto en el menu "Edicion | Vinculos", en elemento me pone la referencia
en notacion L1C1.

> Para reproducir el problema en Office2003 SP2 (WorkAround)

1) Exactamente lo mismo ;-), solo que en el paso 9), en elemento me pone la
referencia en notacion F1C1, y es lo que me causa los problemas.

NOTA IMPORTANTE: En el grupo de ".es.excel" ya me han ayudado a llegar a
'localizar' el problema, y Hector Miguel a tenido la gentileza de probar los
pasos anteriores, pero al tener Office2000 y 2003 en la misma maquina, el
problema no se reproduce, puesto que la version de Microsoft Graph es la
misma (o no, pero quizas comparte la configuracion local) para ambos Office.

PREGUNTA:

¿ Como cambio la configuracion de Microsoft Graph para que me reconozco L1C1
?

Porque cambiar los 'tropecientos' PPTs con sus correspondientes 'cienes y
cienes' de vinculos no es plan :-), aparte de que los usuarios seguiran
durante una temporada trabajando unos con Off2000 y otros con Off2003.

Saludos y gracias por anticipado.



Preguntas similares