Forums Últimos mensajes - Powered by IBM
 

Multiplicar un valor en función de cuatro variables

27/06/2012 - 12:42 por javiermonforte84 | Informe spam
Buenas,
hay alguien que pueda ayudarme con esto??

10 - 1
15 - 2
20 - 3
25 - 4

Si "X" es igual a "10" debe multiplicarse por "1"
Si "X" es igual a "15" debe multiplicarse por "2"
Si "X" es igual a "20" debe multiplicarse por "3"
Si "X" es igual a "25" debe multiplicarse por "4"

Muchas gracias!!
 

Leer las respuestas

#1 Pedro F. Pardo
27/06/2012 - 13:53 | Informe spam
El miércoles, 27 de junio de 2012 11:40:22 UTC+1, javiermonforte84 escribió:
Buenas,
hay alguien que pueda ayudarme con esto??

10 - 1
15 - 2
20 - 3
25 - 4

Si "X" es igual a "10" debe multiplicarse por "1"
Si "X" es igual a "15" debe multiplicarse por "2"
Si "X" es igual a "20" debe multiplicarse por "3"
Si "X" es igual a "25" debe multiplicarse por "4"

Muchas gracias!!



Escribes el valor de X en la celda A1
en B1 puedes escribir la fórmula...

=SI(A1;A1*1;SI(A1;A1*2;SI(A1 ;A1*3;SI(A1%;A1*4;""))))

Esta fórmula funciona exactamente como tu explicas arriba, pero si el numero que escribes no es ninguno de esos cuatro, no escribe nada. Es decir...
si escribes 25>>>devuelve 100 (25*4) pero si escribes 23, no devuelve nada.
¿Es eso lo que buscas o buscas una función lineal que devuelva todos los valores intermedios 16, 17, 22, 23,... entre cada uno de los puntos?

Preguntas similares