Forums Últimos mensajes - Powered by IBM
 
Tags Palabras claves

Nombres de hojas

23/09/2006 - 16:47 por Adolfo Gerardo Guzman Sanchez | Informe spam
Que tal tengo un libro con un numero muy grande de hojas quisiera obtener el
nombre de todas las hojas como puedo obtener estos nombres?

Muchas gracias
 

Leer las respuestas

#1 KL
23/09/2006 - 18:51 | Informe spam
Hola Adolfo,

Op1: Nombre Definido con Macrofuncion de Excel4

- menu Insertar>Nombre>Definir...
- en el cuadro 'Nombre': Hojas
- en el cuadro 'Se refiere a' introducir la siguiente formula:
=INDICAR.LIBRO(1+0*HOY())
- pulsar el boton Anadir
- pulsar el boton Aceptar.
- en una celda en la hoja introducir la siguiente formula y copiarla hacia abajo:
=SI(ESERROR(INDICE(Hojas;FILA(A1)));"";INDICE(Hojas;FILA(A1)))

Notas:
- Este metodo NO es recomendado para XL97 o 2000 ya que al intentar copiar celdas que contienen nombresx con macrofunciones de una
hoja a otra, Excel se cierra provocando la perdida de todos los datos no guardados.
- La parte +0*HOY() esta para que la formula sea volatil y se actualize en tiempo real.
- La formula no se actualiza automaticamente al insertar nueva hoja (pero si, al eliminarlas o cambiar de nombre), es necesario un
recalculo de formulas adicional.

Op2: Macros

Ejecuta el siguiente codigo VBA desde cualquier modulo VBA de tu libro.

Sub test()
With Worksheets.Add(Sheets(1))
.Name = "Indice"
For i = 1 To Worksheets.Count
.Cells(i, 1) = Worksheets(i).Name
Next i
End With
End Sub

Saludos,
KL


"Adolfo Gerardo Guzman Sanchez" wrote in message news:
Que tal tengo un libro con un numero muy grande de hojas quisiera obtener el nombre de todas las hojas como puedo obtener estos
nombres?

Muchas gracias

Preguntas similares