Forums Últimos mensajes - Powered by IBM
 

Porque hace esto ?

06/09/2012 - 13:37 por Vipapi | Informe spam
Mirad, tengo una hoja donde en A29 tengo =hoy() con lo cual en esta celda cada dia tengo la fecha actualizada.

En la celda O32 le pongo esta formula =SI(A29>30/9/12;1;0)
Pues lo que no me puedo explicar es porque me pone un 1, si hoy es inferior al 30/9/12 y deberia ponerme el 0

Si giro el signo y lo dejo asi =SI(A29<30/9/12;1;0) es cuando me pone el 0

Alguien me puede ayudar a resolver esto ?

Lo curioso del caso es que en la celda L32 tengo la misma formula =SI(A29>31/8/12;1;0) y me pone el 1 dado que hoy es superior al 31 de agosto.
 

Leer las respuestas

#1 Juan Español
07/09/2012 - 15:15 | Informe spam
Hola Vipapi:

"Vipapi" escribió en el mensaje de noticias
news:
Mirad, tengo una hoja donde en A29 tengo =hoy() con lo cual en esta celda
cada dia tengo la fecha actualizada.

En la celda O32 le pongo esta formula =SI(A29>30/9/12;1;0)
Pues lo que no me puedo explicar es porque me pone un 1, si hoy es
inferior al 30/9/12 y deberia ponerme el 0


No tienes razón, tiene que poner 1, porque 30/09/12 es 30 dividido 12
dividido 12 = 0,277777778
por eso te pone 1.
Si pusieras

=SI(A19>FECHA(2012;9;30);1;0)

( ojo que FECHA(12;9;30) = 30/09/1912)

entonces te pondría 0 (hasta el 30/09/2012)



Si giro el signo y lo dejo asi =SI(A29<30/9/12;1;0) es cuando me pone el 0

Alguien me puede ayudar a resolver esto ?

Lo curioso del caso es que en la celda L32 tengo la misma formula
=SI(A29>31/8/12;1;0) y me pone el 1 dado que hoy es superior al 31 de
agosto.



No te pone 1 por lo que tú dices sino porque 31/8/12 (0,322916667) es menor
que 41158.

Saludos.-

Preguntas similares