Forums Últimos mensajes - Powered by IBM
 

Problema al Agregar la base de datos de contenido

21/12/2007 - 14:01 por Marcos | Informe spam
Hola a todos:

Tengo un escenario de un NLB con dos ordenadores para servir web, un
servidor sql y un servidor de aplicaciones. En este servidor está instalado
el SPS 2003 sobre sql 2000, a demás de otras aplicaciones.
Hemos montado un MOSS 2007 en esa arquitectura y creando un sitio nuevo,
asta aquí todo funciona todo perfectamente.

El problema es que estoy intentando restaurar un backup de un portal
desarrollado en otra máquina... Y no ha creado bien la aplicación web, pero
si ha restaurado la base de datos. He creado una aplicación web nueva y
despues he intentado añadir la base de datos desde "Administración central >
Administración de aplicaciones > Bases de datos de contenido > Agregar base
de datos de contenido " y da un "Error desconocido". También he intentado
añadir la base de datos desde linea de comandos con "stsadm -o addcontentdb"
y da un "login failed for user 'Dominio\Administrador'".

El usuario tiene permisos en la base de datos y de hecho puedo agregar la
base de datos de contenido en una aplicación web de una instalación MOSS de
prueba en otra máquina ajena a la arquitectura que he mencionado antes.

¿Alguien tiene el mismo problema o sabe a que puede ser debido?

Gracias por adelantado

MAC
 

Leer las respuestas

#1 lpiacono
22/12/2007 - 10:31 | Informe spam
Marcos,

He tratado de entender tu pregunte lo mejor posible. Disculpa si mal
interprete algun aspecto del mismo.

Segun entiendo, estas intentando migrar una base de datos de un portal de
SPS2003 a tu nueva instalacion de MOSS 2007.

Para esto, haz restaurado un backup de la base de datos con prefijo _SITE
con un nuevo nombre y has intentado adjuntar el mismo utilizando STSADM y la
pagina de administracion central.

Desde la pagina recibes un error desconocido y utilizando STSADM recibes un
access is denied.

Mi unica recomendacion con problemas de este tipo es que te asegures de
estar ejecutando STSADM estando logueado con el usuario que esta corriendo
los servicios de Sharepoint 2007, es decir el system account.

Si sigues recibiendo problemas, ya deberias investigar que esta causando el
problemas en los logs ULS de MOSS 2007.

Si podrias darme mas detalles, quizas te podria dar una mejor mano.

Suerte con eso!

"Marcos" wrote:

Hola a todos:

Tengo un escenario de un NLB con dos ordenadores para servir web, un
servidor sql y un servidor de aplicaciones. En este servidor está instalado
el SPS 2003 sobre sql 2000, a demás de otras aplicaciones.
Hemos montado un MOSS 2007 en esa arquitectura y creando un sitio nuevo,
asta aquí todo funciona todo perfectamente.

El problema es que estoy intentando restaurar un backup de un portal
desarrollado en otra máquina... Y no ha creado bien la aplicación web, pero
si ha restaurado la base de datos. He creado una aplicación web nueva y
despues he intentado añadir la base de datos desde "Administración central >
Administración de aplicaciones > Bases de datos de contenido > Agregar base
de datos de contenido " y da un "Error desconocido". También he intentado
añadir la base de datos desde linea de comandos con "stsadm -o addcontentdb"
y da un "login failed for user 'Dominio\Administrador'".

El usuario tiene permisos en la base de datos y de hecho puedo agregar la
base de datos de contenido en una aplicación web de una instalación MOSS de
prueba en otra máquina ajena a la arquitectura que he mencionado antes.

¿Alguien tiene el mismo problema o sabe a que puede ser debido?

Gracias por adelantado

MAC

Preguntas similares