Forums Últimos mensajes - Powered by IBM
 

Problema con control asp y MOSS2007

10/12/2007 - 18:06 por jman | Informe spam
Acabo de desarrollar un control asp.net que se comporta de forma extraña
cuando lo inserto en una página en MOSS 2007, aunque no en WSS 3.0,

Cada vez que se carga la página, Sherepoint me dice que ha sido editada
desde la última vez (como si la hubiera editado con Sharepoint Designer) y
que tengo que
recargarla. Cuando la recargo, el mensaje vuelve a aparecer una y otra vez.
No importa cuál sea la página, basta con que tenga insertado mi control para
que suceda. Y si lo inserto en una master page, ocurrirá en todas las
páginas que la utilicen.

Lo único que se me ocurre que pueda estar provocando esto es que en tiempo
de ejecución, usando javascript, cambio la propiedad action del formulario
html generado por Sharepoint y hago un submit, con lo cual se carga una
página distinta de la que inicialmente estaba configurada. Lo más raro de
todo esto es que funciona perfectamente en WSS 3.0, pero no así en MOSS
2007.
 

Leer las respuestas

#1 Elecktrus
11/12/2007 - 10:58 | Informe spam
Hola, jman:
MOSS 2007 tiene algunso tipos de sitio (de publicacion, p.ej) que no existen
en WSS. Se me ocurre que dentro del MOSS te crees un nuevo sitio, usando una
de las plantillas que si existen en WSS (por ejemplo, sitio de grupo, o sitio
de colaboracion) y pruebes a insertar alli tu webpart, a ver si hay funciona.

"jman" wrote:

Acabo de desarrollar un control asp.net que se comporta de forma extraña
cuando lo inserto en una página en MOSS 2007, aunque no en WSS 3.0,

Cada vez que se carga la página, Sherepoint me dice que ha sido editada
desde la última vez (como si la hubiera editado con Sharepoint Designer) y
que tengo que
recargarla. Cuando la recargo, el mensaje vuelve a aparecer una y otra vez.
No importa cuál sea la página, basta con que tenga insertado mi control para
que suceda. Y si lo inserto en una master page, ocurrirá en todas las
páginas que la utilicen.

Lo único que se me ocurre que pueda estar provocando esto es que en tiempo
de ejecución, usando javascript, cambio la propiedad action del formulario
html generado por Sharepoint y hago un submit, con lo cual se carga una
página distinta de la que inicialmente estaba configurada. Lo más raro de
todo esto es que funciona perfectamente en WSS 3.0, pero no así en MOSS
2007.



Preguntas similares