Forums Últimos mensajes - Powered by IBM
 

problema en cursor

24/02/2005 - 19:46 por gfn | Informe spam
Saludos a todos
Tengo el siguiente problema: Al generar un informe estoy creando un
cursor (curReport) utilizando varias tablas, el informe se genera y se
imprime sin problema y cierro el formulario, pero cuando quiero abrir otro
formulario que activa algunas de las tablas usadas en el cursor me manda
el mensaje de que la tabla ya esta en uso. He incluido las siguientes
sentencias despues de usar el cursor:
Use in curReport
relase cursor curReport
pero aun asi sigo teniendo el mismo problema, el cual se elimina
unicamente escribiendo close all tables, que no es lo que deseo hacer.
Agradezco su ayuda.

salu


PortalFox :: Nada corre como un zorro
http://www.portalfox.com

PortalFox - NNTP Forum Gateway
 

Leer las respuestas

#1 Ana María Bisbé York
24/02/2005 - 22:25 | Informe spam
Hola:

El problema no es cerrar curReport, el problema es cerrar las tablas que
inevitablemente se abren para crear curReport, esas que indicas en la
cláusula FROM del comando select.

El cursor creado, curReport, se libera sólo al salir del formulario que lo
creó.

Saludos,

Ana
www.amby.net

"gfn" escribió en el mensaje
news:%
Saludos a todos
Tengo el siguiente problema: Al generar un informe estoy creando un
cursor (curReport) utilizando varias tablas, el informe se genera y se
imprime sin problema y cierro el formulario, pero cuando quiero abrir otro
formulario que activa algunas de las tablas usadas en el cursor me manda
el mensaje de que la tabla ya esta en uso. He incluido las siguientes
sentencias despues de usar el cursor:
Use in curReport
relase cursor curReport
pero aun asi sigo teniendo el mismo problema, el cual se elimina
unicamente escribiendo close all tables, que no es lo que deseo hacer.
Agradezco su ayuda.

salu


PortalFox :: Nada corre como un zorro
http://www.portalfox.com

PortalFox - NNTP Forum Gateway

Preguntas similares