Forums Últimos mensajes - Powered by IBM
 

Problema de rendimiento en sp

09/03/2006 - 18:48 por Javier | Informe spam
Hola a todos:

Tengo un grave problema de rendimiento al que no encuentro ninguna
explicación plausible. Veréis, hay una serie de stored procedures que se
ejecutan para llevar a cabo unas cargas. Si esas cargas se realizan por la
mañana suelen tardar entre cinco y diez minutos pero... a partir de las cinco
de la tarde se me disparan las cargas a tres horas!!!

De verdad que no sé qué demonios puede estar pasanso y sobre todo no sé cómo
mirarlo. ¿Me podéis echar una mano?

Gracias,

Javier
 

Leer las respuestas

#1 Guillermo Roldan
09/03/2006 - 19:15 | Informe spam
Hola Javier,

Pueden ser multitud de cosas, pero en principio, lo más lógico podría ser un
problema de bloqueo, lo cual, desde el Administrador Corporativo es fácil de
comprobar (desde Administración -> Actividad Actual).

Un error típico, ocurre cuando programadores o administradores, empiezan a
"jugar" con el Administrador Corporativo, con la opción de Abrir una tabla
para ver y/o modificar sus registros. Esto en ocasiones crea bloqueos.

También podrían ser bloqueos debidos a errores de programación, etc.

Puedes empezar por aquí, ya que por la tarde, imagino que habrá menos gente
trabajando. Cuentanos, y te seguiremos indicando.

Saludos,
Guillermo Roldán
"Javier" escribió:

Hola a todos:

Tengo un grave problema de rendimiento al que no encuentro ninguna
explicación plausible. Veréis, hay una serie de stored procedures que se
ejecutan para llevar a cabo unas cargas. Si esas cargas se realizan por la
mañana suelen tardar entre cinco y diez minutos pero... a partir de las cinco
de la tarde se me disparan las cargas a tres horas!!!

De verdad que no sé qué demonios puede estar pasanso y sobre todo no sé cómo
mirarlo. ¿Me podéis echar una mano?

Gracias,

Javier

Preguntas similares