Forums Últimos mensajes - Powered by IBM
 

Problema UPDATE - SQL

23/12/2004 - 02:27 por Desarrollo | Informe spam
Tengo un problema al utilizar el comando update sql

Select tmpcapt
Scan All
Update usermnu Set ;
usermnu.acceso=tmpcapt.acceso,;
usermnu.Modif=tmpcapt.Modif ;
WHERE usermnu.idunico=tmpcapt.id_usermnu
Endscan

En este lado no tengo ningun problema, pero

With Thisform.container1
Update usuarios Set ;
clave=Alltrim(.text1.Value),;
nivel=.combo1.ListItemId,;
nombre=Alltrim(.text2.Value),;
puesto=Alltrim(.text4.Value),;
depto=Alltrim(.text3.Value),;
estatus=.combo2.ListItemId,;
terminal=Alltrim(Left(Sys(0),At("#",(Sys(0)))-1)),;
id_usuario=_Screen.iduser ;
WHERE id_unico=Thisform.id_user
Endwith

aquí es donde tengo el problema, marca un error que dice que no se encuentra
el alias 'TEXT1', ??????, si quito la línea "clave=Alltrim(.text1.Value),;",
marca el mismo error pero con el COMBO1 y así sucesivamente

Porque pasa esto ??? según yo debe de funcionar sin problemas, que es lo que
me hace falta o que estoy omitiendo ??, utilizo vfp8 sp1, winxp pro sp2,
bases dbc, desde ya gracias por la ayuda recibida, pásenla bien y felices
fiestas !!!!!

Saludos !!!!
 

Leer las respuestas

#1 Esparta Palma
23/12/2004 - 02:34 | Informe spam
Pasa los .YYYxxxx.value a variables de memoria, suele suceder...


Espartaco Palma
SysOp www.PortalFox.com
Mexico

Desarrollo wrote:
Tengo un problema al utilizar el comando update sql

Select tmpcapt
Scan All
Update usermnu Set ;
usermnu.acceso=tmpcapt.acceso,;
usermnu.Modif=tmpcapt.Modif ;
WHERE usermnu.idunico=tmpcapt.id_usermnu
Endscan

En este lado no tengo ningun problema, pero

With Thisform.container1
Update usuarios Set ;
clave=Alltrim(.text1.Value),;
nivel=.combo1.ListItemId,;
nombre=Alltrim(.text2.Value),;
puesto=Alltrim(.text4.Value),;
depto=Alltrim(.text3.Value),;
estatus=.combo2.ListItemId,;
terminal=Alltrim(Left(Sys(0),At("#",(Sys(0)))-1)),;
id_usuario=_Screen.iduser ;
WHERE id_unico=Thisform.id_user
Endwith

aquí es donde tengo el problema, marca un error que dice que no se encuentra
el alias 'TEXT1', ??????, si quito la línea "clave=Alltrim(.text1.Value),;",
marca el mismo error pero con el COMBO1 y así sucesivamente

Porque pasa esto ??? según yo debe de funcionar sin problemas, que es lo que
me hace falta o que estoy omitiendo ??, utilizo vfp8 sp1, winxp pro sp2,
bases dbc, desde ya gracias por la ayuda recibida, pásenla bien y felices
fiestas !!!!!

Saludos !!!!


Preguntas similares