Forums Últimos mensajes - Powered by IBM
 

Problemas con calendario

03/08/2005 - 14:42 por JACS | Informe spam
Hola, os relato mi odisea:

1º. Muy buenas, otra vez a dar la lata, seria posible que poniendo en una
celda
el nombre de un mes del año por ejemplo Julio, me saliera en una fila
los
dias que tiene y en la de abajo la inicial del dia de la semana? Muchas
GRACIAS anticipadas a todos.

2º. En A1 pones el nombre del mes y del año, no solo el mes. Por ejemplo:
Ago-05
En A2 ingresas el número 1
En B2 pones esta fórmula: =SI(A2<DIA(FIN.MES($A$1;0));A2+1;"")
y la copias hasta AE2
En A3 pones esta fórmula: =ELEGIR(DIASEM(FECHA(AÑO($A$1),MES
($A$1),A2),2),"L","M","M","J","V","S","D")
y la copias hasta G3
En H3 va la siguiente fórmula: =SI(H2<>"",A3,"")
y la copias hasta AE3.

Y el problema que tengo es que cuando meto la formula en B2, se queda en
blanco
pero si el signo < lo cambio por > me funciona y no entiendo el porque de
este cambio.

Muchas GRACIAS anticipadas.
 

Leer las respuestas

#1 Manolo
03/08/2005 - 20:31 | Informe spam
Hola JACS, revisa que el número 1de la celda A2 no esté ingresado como
texto.

Manolo

"JACS" escribió en el mensaje
news:
Hola, os relato mi odisea:

1º. Muy buenas, otra vez a dar la lata, seria posible que poniendo en una
celda
el nombre de un mes del año por ejemplo Julio, me saliera en una fila
los
dias que tiene y en la de abajo la inicial del dia de la semana?


Muchas
GRACIAS anticipadas a todos.

2º. En A1 pones el nombre del mes y del año, no solo el mes. Por ejemplo:
Ago-05
En A2 ingresas el número 1
En B2 pones esta fórmula: =SI(A2<DIA(FIN.MES($A$1;0));A2+1;"")
y la copias hasta AE2
En A3 pones esta fórmula: =ELEGIR(DIASEM(FECHA(AÑO($A$1),MES
($A$1),A2),2),"L","M","M","J","V","S","D")
y la copias hasta G3
En H3 va la siguiente fórmula: =SI(H2<>"",A3,"")
y la copias hasta AE3.

Y el problema que tengo es que cuando meto la formula en B2, se queda en
blanco
pero si el signo < lo cambio por > me funciona y no entiendo el porque de
este cambio.

Muchas GRACIAS anticipadas.



Preguntas similares