Forums Últimos mensajes - Powered by IBM
 

Problemas con enlaces de sitios creados a partir de plantillas según permisos.

09/11/2004 - 16:20 por Tako | Informe spam
Hola grupo

A ver si alguien puede echar algo de luz sobre otra cosa rara que he
visto en el SPS2003, esta vez a nivel de permisos:

Resulta que tengo una plantilla, estas plantilla dentro tiene una lista
de enlaces, si se crea un sitio nuevo en base a esa plantilla todo va bien,
sin embargo si lo creo que un usuario que no tenga el permiso "Agregar y
personalizar páginas:" genera mal el WebPart de enlaces; exactamente lo que
sucede es que el enlace que permite añadir un elemento nuevo y el enlace del
titulo que permite ir a la pantalla que te muestra todos los elementos de
forma "maximizada" se genera mal, en lugar de apunta a "AllItems.aspx"
apunta a

/_layouts/3082/error.aspx?ErrorText=Formulario%20no%20disponible%20para%20es
ta%20lista%2c%20panel%20de%20discusi%c3%b3n%2c%20encuesta%20o%20biblioteca%2
0de%20documentos%2e&

¿Alguien tiene alguna idea de por que es esto?

Francamente, me parece muy bien que si no tienes permisos para "Agregar
y personalizar páginas" no te deje modificarlas, pero no tiene sentido que
te permita generar un sitio que enlaces incorrectos (aunque quizás haya
alguna lógica oculta que se me escape)

Graciasssss
 

Leer las respuestas

#1 Gustavo
09/11/2004 - 21:10 | Informe spam
Nuestro BEPDOM vuelve al ataque...
A ver si te entiendo bien: Tienes una plantilla (Template), con una lista
por dentro que a veces funciona bien y otras no tanto (dependiendo de los
derechos del usuario). Voy por el buen camino?
Si es asi, en el ONET.XML del template tienes una seccion <ListTemplates> en
donde declaras tus listas (logico, no?). Una de las propiedades de cada
ListTemplate es su "SecurityBits", que son dos numeros, uno con los derechos
para leer y el otro con los derechos para escribir. Cual es cual, no me
acuerdo, pero esta en el SDK, asi como sus valores. Si te pones a jugar con
estos numeritos, a lo mejor encuentras la forma de que el asunto te funcione.
Saludos otra vez,
Gustavo


"Tako" wrote:



Hola grupo

A ver si alguien puede echar algo de luz sobre otra cosa rara que he
visto en el SPS2003, esta vez a nivel de permisos:

Resulta que tengo una plantilla, estas plantilla dentro tiene una lista
de enlaces, si se crea un sitio nuevo en base a esa plantilla todo va bien,
sin embargo si lo creo que un usuario que no tenga el permiso "Agregar y
personalizar páginas:" genera mal el WebPart de enlaces; exactamente lo que
sucede es que el enlace que permite añadir un elemento nuevo y el enlace del
titulo que permite ir a la pantalla que te muestra todos los elementos de
forma "maximizada" se genera mal, en lugar de apunta a "AllItems.aspx"
apunta a

/_layouts/3082/error.aspx?ErrorText=Formulario%20no%20disponible%20para%20es
ta%20lista%2c%20panel%20de%20discusi%c3%b3n%2c%20encuesta%20o%20biblioteca%2
0de%20documentos%2e&

¿Alguien tiene alguna idea de por que es esto?

Francamente, me parece muy bien que si no tienes permisos para "Agregar
y personalizar páginas" no te deje modificarlas, pero no tiene sentido que
te permita generar un sitio que enlaces incorrectos (aunque quizás haya
alguna lógica oculta que se me escape)

Graciasssss




Preguntas similares