Forums Últimos mensajes - Powered by IBM
 

Problemas con windows 2000 2

18/05/2005 - 11:12 por Tecnicos Aydai | Informe spam
Hola a todos!!!
Vereis, tengo el siguiente codigo :

Dim oConnexion As New OleDbConnection

oConnexion.ConnectionString = g_conexion

oDataAdapter = New OleDbDataAdapter("Select * from GE0F1TGE order by
tge1_codigo", oConnexion)



Dim oCB As OleDbCommandBuilder = New OleDbCommandBuilder(oDataAdapter)



oDataMensajes = New DataSet

oConnexion.Open()

oDataAdapter.Fill(oDataMensajes, "Mensajes")

oConnexion.Close()

El cual en windows Xp me funciona perfectamente, y en un windows 2000 que
tenga instalado el Visual .Net 2003 tambien me funciona, en cambio, en un
windows 2000, limpio, el cual le he instalado el framework, no me funciona y
no tengo ni idea del porque, el error me lo da al hacer el open. ¿Podrian
hecharme una mano?? Lo agradeceria
mucho. Un saludo y gracias
 

Leer las respuestas

#1 Jorge Serrano [MVP VB]
18/05/2005 - 12:34 | Informe spam
Asegúrate que tienes la versión correcta de MDAC.

http://msdn.microsoft.com/data/mdac...fault.aspx

Utiliza la utilidad Component Checker para chequear la versión MDAC que usas
y comprueba que en tu Windows 2000 está todo en orden. Esta utilidad la
encontrarás en la misma web.

Jorge Serrano Pérez
Microsoft MVP VB.NET
PortalVB.com
http://www.portalvb.com/
Weblog de Jorge Serrano
http://weblogs.golemproject.com/jorge/


"Tecnicos Aydai" wrote:

Hola a todos!!!
Vereis, tengo el siguiente codigo :

Dim oConnexion As New OleDbConnection

oConnexion.ConnectionString = g_conexion

oDataAdapter = New OleDbDataAdapter("Select * from GE0F1TGE order by
tge1_codigo", oConnexion)



Dim oCB As OleDbCommandBuilder = New OleDbCommandBuilder(oDataAdapter)



oDataMensajes = New DataSet

oConnexion.Open()

oDataAdapter.Fill(oDataMensajes, "Mensajes")

oConnexion.Close()

El cual en windows Xp me funciona perfectamente, y en un windows 2000 que
tenga instalado el Visual .Net 2003 tambien me funciona, en cambio, en un
windows 2000, limpio, el cual le he instalado el framework, no me funciona y
no tengo ni idea del porque, el error me lo da al hacer el open. ¿Podrian
hecharme una mano?? Lo agradeceria
mucho. Un saludo y gracias



Preguntas similares