Forums Últimos mensajes - Powered by IBM
 

problemas consulta paso a traves de SQL

03/08/2005 - 14:31 por Norman Romero | Informe spam
Estoy trabajando con VFP7 -ODBC y Base de datos VFP7.
El problema consiste en que la información que se digita en
las estaciones de trabajo, al realizar una consulta, los
registros nuevos no aparecen en la consulta; o si se tiene
una sesión (tarea) en desarrollo y en otra abierta la base
de datos e ingresando registros, al realizar una consulta
podrá observar que los nuevos registros no aparecen, no
puedo realizar directamente la consulta sobre la base de
datos ya que la idea es migrar a otro motor de B.D, y
atendría que realizar doble trabajo.
Lo curioso es que se sale de la sesion o instancia de
desarrollo e ingresa y consulta ya se puede ver la
información actualizada
Lo he intentado con el OLE DB 8 y 9, las primeras veces lo
hace bien y la consulta trae la información real
(actualizada), pero en cualquier momento comienza a generar
el error de tabla corrupta (este problema ya lo han
reportado en algunos grupos o portales pero realmente no
dan la solución).
Quisiera pedirle el favor de ilustrarme como solucionar el
inconveniente.

Muchas gracias, Norman
 

Leer las respuestas

#1 Angel J. Hernández M.
03/08/2005 - 15:58 | Informe spam
Deberías postear esto en el foro de VFP.

Saludos,


Angel J. Hernández M.
MCP - MCAD - MCSD - MCDBA
http://groups.msn.com/desarrolladoresmiranda
http://www.consein.com


"Norman Romero" wrote in message
news:01b901c59827$496eecc0$
Estoy trabajando con VFP7 -ODBC y Base de datos VFP7.
El problema consiste en que la información que se digita en
las estaciones de trabajo, al realizar una consulta, los
registros nuevos no aparecen en la consulta; o si se tiene
una sesión (tarea) en desarrollo y en otra abierta la base
de datos e ingresando registros, al realizar una consulta
podrá observar que los nuevos registros no aparecen, no
puedo realizar directamente la consulta sobre la base de
datos ya que la idea es migrar a otro motor de B.D, y
atendría que realizar doble trabajo.
Lo curioso es que se sale de la sesion o instancia de
desarrollo e ingresa y consulta ya se puede ver la
información actualizada
Lo he intentado con el OLE DB 8 y 9, las primeras veces lo
hace bien y la consulta trae la información real
(actualizada), pero en cualquier momento comienza a generar
el error de tabla corrupta (este problema ya lo han
reportado en algunos grupos o portales pero realmente no
dan la solución).
Quisiera pedirle el favor de ilustrarme como solucionar el
inconveniente.

Muchas gracias, Norman

Preguntas similares