Forums Últimos mensajes - Powered by IBM
 

RAISERROR no encuentra la entrada .... ein?

01/02/2005 - 19:18 por Rodriguess | Informe spam
Hola a todos.

Estoy haciendo pruebas con mi MSDE y mi aplicacion en visual basic,
intentando insertar unos pocos valores en mi tabla, pero al ejecutarla me da
el siguiente error:

Run-Time error '-2147217900 (80040e14)':
RAISERROR no encuentra la entrada del error 50009 en sysmessages.

este es el código que estoy utilizando...

Public Sub ConnectToSql()

Dim cmd1 As String

cn.ConnectionTimeout = 25
cn.Provider = "sqloledb"
cn.Properties("Data Source").Value = ""
cn.Properties("Initial Catalog").Value = ""

cn.Properties("User ID").Value = ""
cn.Properties("Password").Value = ""

cn.Open

cmd1 = "INSERT Maquinas VALUES (20,'1/2/2005',1,20,200,'color')"

Set rs = New ADODB.Recordset

rs.Open cmd1, cn (EN ESTA LINEA ME DA EL ERROR)

cn.Close

End Sub

Me podeis ayudar??? que estoy haciendo mal???

Muchas Gracias!
 

Leer las respuestas

#1 Gustavo Larriera [MVP]
01/02/2005 - 20:33 | Informe spam
Intuyo que hay dos problemas aquí: primero hay un error al ejecutar el
comando (revisar si el INSERT es correcto) y segundo el propio MSDE no
puede responder un error apropiado pues no encuentra la definición del
error.

Los errores superiores al 50009 son errores definidos por el usuario, no
son errores nativos del producto.

Gustavo Larriera, MVP
Uruguay LatAm
http://sqljunkies.com/weblog/gux/
Este mensaje se proporciona "COMO ESTA" sin garantias y no otorga ningun
derecho / This posting is provided "AS IS" with no warranties, and
confers no rights.



"Rodriguess" wrote in message news::
Hola a todos.

Estoy haciendo pruebas con mi MSDE y mi aplicacion en visual basic,
intentando insertar unos pocos valores en mi tabla, pero al ejecutarla me
da
el siguiente error:

Run-Time error '-2147217900 (80040e14)':
RAISERROR no encuentra la entrada del error 50009 en sysmessages.

este es el código que estoy utilizando...

Public Sub ConnectToSql()

Dim cmd1 As String

cn.ConnectionTimeout = 25
cn.Provider = "sqloledb"
cn.Properties("Data Source").Value = ""
cn.Properties("Initial Catalog").Value = ""

cn.Properties("User ID").Value = ""
cn.Properties("Password").Value = ""

cn.Open

cmd1 = "INSERT Maquinas VALUES (20,'1/2/2005',1,20,200,'color')"

Set rs = New ADODB.Recordset

rs.Open cmd1, cn (EN ESTA LINEA ME DA EL ERROR)

cn.Close

End Sub

Me podeis ayudar??? que estoy haciendo mal???

Muchas Gracias!

Preguntas similares