Forums Últimos mensajes - Powered by IBM
 

Reducir y mejorar fórmula

20/05/2007 - 12:37 por Ernesto | Informe spam
Hola a todos.
A ver si me podría alguien ayudar.
Tengo una fórmula, que se repite bastantes veces, en distintas celdas y
columnas y creo que se podría reducir y 'afinar'.
La fórmula en cuestión es:
=SI($B77="A";SI($G77=1;$H$3;SI($G77=2;$H$3/2;SI($G77=3;$H$3/3;SI($G77=4;$H$3/4;SI($G77=5;$H$3/5;SI($G77=6;$H$3/6)))))))
En cierta ocasión Héctor Miguel me
dejó:=SI(CJ524úLSO;"";SI(CJ524=$H$3/2;"";SI(CJ524=$H$3/3;$H$3/3;SI(CJ524=$H$3/4;$H$3/4;SI(CJ524=$H$3/5;$H$3/5;SI(CJ524=$H$3/6;$H$3/6)))))),
en:
=SI(O(CJ524úLSO;CJ524=$H$3/2);"";SI(ESNUMERO(COINCIDIR($H$3;CJ524*{3\4\5\6};0));CJ524)),yfunciona igual.Soy novato y aún con este ejemplo no me atrevo a 'cambiarla' al formato'*{3\4\5\6};0))', ya que esta hoja es muy valiosa para el trabajo.Gracias y saludos.
 

Leer las respuestas

#1 KL
20/05/2007 - 18:35 | Informe spam
Hola Ernesto,

"Ernesto" wrote in message news:
Hola a todos.
A ver si me podría alguien ayudar.
Tengo una fórmula, que se repite bastantes veces, en distintas celdas y
columnas y creo que se podría reducir y 'afinar'.
La fórmula en cuestión es:
=SI($B77="A";SI($G77=1;$H$3;SI($G77=2;$H$3/2;SI($G77=3;$H$3/3;SI($G77=4;$H$3/4;SI($G77=5;$H$3/5;SI($G77=6;$H$3/6)))))))
En cierta ocasión Héctor Miguel me
dejó:=SI(CJ524úLSO;"";SI(CJ524=$H$3/2;"";SI(CJ524=$H$3/3;$H$3/3;SI(CJ524=$H$3/4;$H$3/4;SI(CJ524=$H$3/5;$H$3/5;SI(CJ524=$H$3/6;$H$3/6)))))),
en:
=SI(O(CJ524úLSO;CJ524=$H$3/2);"";SI(ESNUMERO(COINCIDIR($H$3;CJ524*{3\4\5\6};0));CJ524)),yfunciona igual.Soy novato y aún con
este ejemplo no me atrevo a 'cambiarla' al formato'*{3\4\5\6};0))', ya que esta hoja es muy valiosa para el trabajo.Gracias y
saludos.



El ejemplo que expones es literalmente lo siguiente:

=SI($B77="A";SI($G77;$H$3/$G77;0))

o bien

=SI(Y($B77="A";$G77);$H$3/$G77;0)

pero si quieres algo mas generico (tal como te hizo HM en otra ocasion), entonces:

=SI($B77="A";SI(ESNUMERO(COINCIDIR($G77;{1\2\3\4\5\6};0));$H$3/INDICE({1\2\3\4\5\6};COINCIDIR($G77;{1\2\3\4\5\6};0);"")))

Saludos,
KL

Preguntas similares