Forums Últimos mensajes - Powered by IBM
 

seleccion todo un mes en fechas para excel

30/03/2007 - 01:42 por egroj.selarom | Informe spam
me ha surgidio un gran problema, no me considera un novato pero la
verdad ya me trabe con una formula, y no salgo de ella o una pequeña
modificacion, ya que por mas que piensa solo llego a ella, (osea ya me
enfrasque con esa formula) y para salir de ella he dejado el archivo
varios dias sin hacerle nada pero resulta que cuando quiero volver a
hacerlo llego al mismo punto, Por eso les pido "F1" (Ayuda).
el problema es el siguiente:
tengo que selecionar de una BD en Excel la suma de varias de ellas con
varios criterios, el primero que concuerde con un determinado almacen
y el segundo que sea de determinado mes, la formula que utiliso es la
siguiente:
=SUMAPRODUCTO(((Sistema!$P$2:$P$1532)¸)*1,((Sistema!$AN$2:$AN$1532)>$Q$1)*1)
donde sistema es la Base de Datos
B8 = a Almacen
P2:P1532 es la columna donde seleciona que almacen va a tomar si
cumple el criterio de B8,
AN2:AN1532 es la columna donde seleciona que fechas tome si cumple el
criterio de ser mayor o igual a $Q$1.
Ahora el problema es que no se como definir que solo tome las fechas
de AN:AN1532 que solo sean de determinado mes es decir de 01 de Marzo
al 25 de Marzo por que del 26 de Marzo al 25 de Abril sera el
siguiente corte.

como ven ya me tiene dando bueltas esta formula y no consigo
dominarla por que solome toma el criteri de mayor que sierta fecha
que yo le haya puesto. bueno si alguin sabe y me entiende la
agradecere la ayuda.
 

Leer las respuestas

#1 Héctor Miguel
30/03/2007 - 08:25 | Informe spam
hola, jorge !

... tengo que selecionar de una BD en Excel la suma de varias de ellas con varios criterios
el primero que concuerde con un determinado almacen
y el segundo que sea de determinado mes, la formula que utiliso es la siguiente:
=SUMAPRODUCTO(((Sistema!$P$2:$P$1532)¸)*1,((Sistema!$AN$2:$AN$1532)>=$Q$1)*1)
donde sistema es la Base de Datos
B8 = a Almacen
P2:P1532 es la columna donde seleciona que almacen va a tomar si cumple el criterio de B8,
AN2:AN1532 es la columna donde seleciona que fechas tome si cumple el criterio de ser mayor o igual a $Q$1.
Ahora el problema es que no se como definir que solo tome las fechas de AN:AN1532 que solo sean de determinado mes
es decir de 01 de Marzo al 25 de Marzo por que del 26 de Marzo al 25 de Abril sera el siguiente corte...



1) la 'forma' en que empleas la funcion sumaproducto te devuelve SOLO 'la cuenta' de los que cumplan con todos los criterios

2) hasta la formula expuesta estas 'comparando' SOLO 2 criterios... [almacen y una 'determinada' fecha 'minima/inicial/de partida/...]

3) [aparentemente] solo te falta incluir la tercera condicion... [la fecha 'imite' ?] -> prueba con algo +/- como...
=sumaproducto(--(rango_almacenes=almacen),--(rango_fechas>=fecha_inicial),--(rango_fechas<=fecha_limite))

4) si deseas 'la suma' de algun rango con importes... deberas agregar dicho rango como un cuarto argumento [+/- como:
=sumaproducto(--(rango_almacenes=almacen),--(rango_fechas>=fecha_inicial),--(rango_fechas<=fecha_limite),rango_a_sumar)

si cualquier duda [o informacion adicional]... comentas ?
saludos,
hector.

Preguntas similares