Forums Últimos mensajes - Powered by IBM
 

Subreports en crystal report

15/06/2006 - 12:07 por Diego \(DCD\) | Informe spam
Hola,

tengo un listado al que tengo enlazado un dataset como origen de datos,
dentro de este mismo listado he creado varios subreports con el mismo origen
de datos, pero los subreports creados no se refrescan ni muestran datos,
incluso he borrado los links del report principal con el subreport para ver
si era ese el problema y no lo es, he comprobado que el origen de datos
contiene filas,le he asignado a cada subrepor el origen de datos con la
propiedad setdatasource, pero nada de nada, ¿alguien sabe qué ocurre? o
cómo refrescar el listado?
gracias y un saludo.
 

Leer las respuestas

#1 Octavio Hernandez
15/06/2006 - 14:05 | Informe spam
Diego,

Creo q tienes que programar un evento para refrescar todos los subreports,
recorriendo todos los objetos del informe padre, determinando cuáles son
subinformes, y en caso positivo haciendo un cast y aplicando el método
Refresh().

Slds - Octavio


"Diego (DCD)" escribió en el mensaje
news:O$
Hola,

tengo un listado al que tengo enlazado un dataset como origen de datos,
dentro de este mismo listado he creado varios subreports con el mismo
origen
de datos, pero los subreports creados no se refrescan ni muestran datos,
incluso he borrado los links del report principal con el subreport para
ver
si era ese el problema y no lo es, he comprobado que el origen de datos
contiene filas,le he asignado a cada subrepor el origen de datos con la
propiedad setdatasource, pero nada de nada, ¿alguien sabe qué ocurre? o
cómo refrescar el listado?
gracias y un saludo.




Preguntas similares