Forums Últimos mensajes - Powered by IBM
 

suma condicional

24/09/2007 - 16:25 por x.masana | Informe spam
Hola,
Me dirijo nuevamente a este foro en busca de vuestra ayuda.
Necesito sumar un rango siempre y cuando la fecha de otro rango sea
igual a un año concreto.
Me explico:
tengo un cuadro de financiación, y necesito agrupar importes en
función del año de vencimiento de la operación.

Ejemplo:
celda a20= 2007

Los datos los tengo de la siguiente forma:
A B C
1 10-10-07 2425
2 10-11-07 2500
3 10-12-07 2525
4 10-01-08 2550
5 10-02-08 2575
6 10-03-08 2600

La fórmula que estoy usando es:
=SUMAR.SI(B1:B5;AÑO(B1:B5)=AÑO(A20);C1:C5)
(quiero sumar todos aquellos valores que tengan como fecha año 2007)

Gracias anticipadas por vuestra ayuda

saludos cordiales
xavier
 

Leer las respuestas

#1 Juan M
24/09/2007 - 16:47 | Informe spam
escribió
Hola,
Me dirijo nuevamente a este foro en busca de vuestra ayuda.
Necesito sumar un rango siempre y cuando la fecha de otro rango sea
igual a un año concreto.
Me explico:
tengo un cuadro de financiación, y necesito agrupar importes en
función del año de vencimiento de la operación.

Ejemplo:
celda a20= 2007

Los datos los tengo de la siguiente forma:
A B C
1 10-10-07 2425
2 10-11-07 2500
3 10-12-07 2525
4 10-01-08 2550
5 10-02-08 2575
6 10-03-08 2600

La fórmula que estoy usando es:
=SUMAR.SI(B1:B5;AÑO(B1:B5)=AÑO(A20);C1:C5)
(quiero sumar todos aquellos valores que tengan como fecha año 2007)

Gracias anticipadas por vuestra ayuda

saludos cordiales
xavier




Hola Xavier,

prueba cualquiera de las siguientes fórmulas,

=SUMAPRODUCTO(--(AÑO(B1:B5)¢0);C1:C5)

=SUMAR.SI(B1:B5;">="&FECHA(A20;1;1);C1:C5)-SUMAR.SI(B1:B5;">="&FECHA(A20+1;1;1);C1:C5)

Un saludo,
Juan

Preguntas similares