Forums Últimos mensajes - Powered by IBM
 

Sumar valores con algunos textos

07/10/2005 - 21:45 por Jorge G | Informe spam
Buenas!
Tengo una columna que debo sumar y en son numeros de otras celdas. en alguna
se muestra el error #¡DIV/0!, ya que no hay ningun valor numerico.
¿como puedo sumar los demas valores sin contar con las celdas que muestran
estos errores, es decir teniendo en cuenta solo los numericos?
Ejemplo:
a1 2
a2 3
a3 #¡DIV/0!
a4 2
a5 7 (suma total).




Intento varias funciones condicionales, pero no se como indicar valores solo
numericos...
Una ayudita!
Jorge G
 

Leer las respuestas

#1 KL
07/10/2005 - 22:23 | Informe spam
Hola Jorge,

En orden de mi preferencia:

Op1: Si no puede haber numeros negativos:
=SUMAR.SI(A1:A4;">0")

Op2: Si puede haber numeros negativos:
=SUMAR.SI(A1:A4;">0")+SUMAR.SI(A1:A4;"<0")

Op3:
=SUMAPRODUCTO(SUMAR.SI(A1:A5;{">0"\"<0"}))

Op4: Formula matricial (se introduce mediante Ctrl+Shift+Enter, no solo
Enter)
=SUMA(SI(ESNUMERO(A1:A4);A1:A4))

Op5: Si solo puede haber un tipo de error y siempre se usaria el Excel en
castellano:
=SUMAR.SI(A1:A5;"<>#?DIV/0!")

Saludos,
KL


"Jorge G" wrote in message
news:
Buenas!
Tengo una columna que debo sumar y en son numeros de otras celdas. en
alguna
se muestra el error #?DIV/0!, ya que no hay ningun valor numerico.
?como puedo sumar los demas valores sin contar con las celdas que muestran
estos errores, es decir teniendo en cuenta solo los numericos?
Ejemplo:
a1 2
a2 3
a3 #?DIV/0!
a4 2
a5 7 (suma total).




Intento varias funciones condicionales, pero no se como indicar valores
solo
numericos...
Una ayudita!
Jorge G

Preguntas similares