Forums Últimos mensajes - Powered by IBM
 

Validar datos/opciones por fechas

29/05/2008 - 09:10 por gongi | Informe spam
Hola, por favor si alguien me indica como seguir o tratar lo
siguiente:
En una hoja de cálculo, Filas son registros/nuevo registro, Columnas
Campos/registro, en A pongo un nº de expediente, en B celda con lista
de Validación con distintas opciones (En curso, tramitado,
pagado..) y en C =SI(B4="OFERTA";HOY();"") D SI(B4="TRAMITADO";HOY();"") y así siguientes columnas para cada
opción. La cuestión es poder hacer un seguimiento por fechas de cada
etapa, pero al basarme en una celda con lista de validación, cuando
cambio la opción pierdo la fecha de la anterior.Como podría mantener
un "histórico" de fechas, de manera que a cada opción le quedara
asignada una primera y única fecha.?

Muchas gracias por vuestra colaboración.
 

Leer las respuestas

#1 gongi
30/05/2008 - 15:22 | Informe spam
On 29 mayo, 19:20, "Héctor Miguel"
wrote:
hola, (domingo ?) ???

> Asi, por codigo, me va de perlas, aunque es curioso que el Case no acepta mayusculas
> pero eso ni tiene ninguna importancia...

(bueno...) de que las acepta, las acepta ;) es solo que...
he "forzado" una comparacion en minusculas con la instruccion: -> Select Case LCase(.Value)
la razon?... debido a que las comparaciones (en vba) son "textualmente precisas" (may/min)usculas
a menos que al principio del modulo (area de declaraciones) uses la instruccion: -> Option Compare Text

pero... puesto que en la celda validada (aun) puedes "entrar en directo", podrias usar diferente capitalizacion -?-
la validacion si te acepta diferencias en las (may/min)usculas... pero... el codigo NO :-((

saludos,
hector.



Gracias por todo, Hector , si quito el LCase parece que funciona
Me permito hacer otra consulta al grupo. Para el código que me has
facilitado, ¿ como encajo el siguiente código de manera que pueda
cambiar el formato de la celda activa ?


Private Sub Worksheet_Change(ByVal Target As Range)
If Application.Intersect(Target, [A1:A30]) Is Nothing Then Exit
Sub
Select Case Target
Case "Angel"
Target.Interior.ColorIndex = 10
Case "Victor"
Target.Interior.ColorIndex = 11
Case "Bernal"
Target.Interior.ColorIndex = 12
Case "Alex"
Target.Interior.Color = 13
'
' más "cases"
'
Case Else
Target.Interior.ColorIndex = xlColorIndexNone
End Select
End Sub

muchas gracias y saludos

Preguntas similares