Cache Internet Explorer

26/04/2006 - 01:53 por David | Informe spam
Tengo una página Web muy sencilla en HTML, Con una macro de Office sustitullo
una imagen que pertenece a dicha Web, despues de esto cuando recargo la
página no se modifica la imagen.
He añadido a la cabezera el siguiente código que indica en el documento de
Microsoft 234067:
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
Pero el problema persiste.

Cual puede ser la solución.
Todas las pruebas la hago con Internet Explorer 6.0 y Windows Server 2003.

Gracias.
David.
 

Leer las respuestas

#1 Enrique [MVP Windows]
26/04/2006 - 12:44 | Informe spam
Mira a ver si esto te lo soluciona, aunque no está referido a IE6, si no
a versiones anteriores:

**Es posible que la etiqueta "Pragma: No-cache" no impida que se
almacene la página en memoria caché
http://support.microsoft.com/kb/222064/es

De todas formas, me da la impresión de que no se trata de un problema de
la cache de archivos temporales, además dices que "recargando" la
página, no funciona la macro, lo cual confirma mi sospecha. Prueba a
deshabilitar en el cliente la caché de Internet (desde la configuración
del programa), para que siempre se cargue la página actualizada.

Si pruebas con Firefox, es posible que funcione correctamente.


Saludos,
Enrique Cortés
Microsoft MVP - Windows - IE/OE
http://ekort.blogspot.com
(despiértame si me quieres escribir)
Vista x86 (TM) Build 5342
IE 7.0.5335.5 on XPSP2

"Que algo no funcione como tú esperabas
no quiere decir que sea inútil"


Este mensaje se proporciona "como está" sin garantías de ninguna clase,
y no otorga ningún derecho.
This posting is provided "AS IS" with no warranties, and confers no
rights.
________________________________________________________________________________
"David" escribió en el mensaje
news:
Tengo una página Web muy sencilla en HTML, Con una macro de Office
sustitullo
una imagen que pertenece a dicha Web, despues de esto cuando recargo la
página no se modifica la imagen.
He añadido a la cabezera el siguiente código que indica en el documento
de
Microsoft 234067:
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
Pero el problema persiste.

Cual puede ser la solución.
Todas las pruebas la hago con Internet Explorer 6.0 y Windows Server
2003.

Gracias.
David.

Preguntas similares