Forums Últimos mensajes - Powered by IBM
 
Tags Palabras claves

Formula SI(Y(....

07/03/2009 - 18:15 por Luis Hernando Garcia | Informe spam
Hola

Estoy intentando ejecutar la formula
=SI(Y(C12<P0000;"CI";SI(C12<™9999.99;"CD";SI(C12>00000;"OPS";SI(C12>00000;"ODT";0)))))
para un valor definido en la celda C12 pero me aparece error siempre al
guardarla, se que podria usar otra formula para validar pero me exigen usar
=SI(Y(...
Les agradezco la colaboracion

Luis Hernando G.
 

Leer las respuestas

#1 Juan M
07/03/2009 - 20:33 | Informe spam
"Luis Hernando Garcia" escribió
Hola

Estoy intentando ejecutar la formula
=SI(Y(C12<P0000;"CI";SI(C12<™9999.99;"CD";SI(C12>00000;"OPS";SI(C12>00000;"ODT";0)))))
para un valor definido en la celda C12 pero me aparece error siempre al
guardarla, se que podria usar otra formula para validar pero me exigen
usar
=SI(Y(...
Les agradezco la colaboracion

Luis Hernando G.



Hola Luis,

Pues no entiendo la necesidad de emplear el Y o no entiendo que es lo que
debe devolver la fórmula.
La fórmula además presenta un error o una incompatibilidad o un fallo en los
rangos. Si el valor de C12 es mayor de 1000000 siempre devolverá OPS.

Para resolver esto te sugiero la siguiente:
=SI(C12<P0000;"CI";SI(C12<1000000;"CD";SI(C12<1800000;"OPS";"ODT")))

Normalmente para cuando debes elegir una opción de un listado para dar un
tipo de respuesta es recomendable el empleo de funciones de búsqueda como
buscarv, buscar,... donde en una columna pones los límites del rango y en
otra columna pones el valor que debe devolver.

Tampoco entiendo que alguien imponga el empleo de una fórmula, si tan claro
lo tiene que te de la fórmula. Normalemente lo importante es el reslutado,
que sea o no el correcto.

Un saludo,
Juan

Preguntas similares