Forums Últimos mensajes - Powered by IBM
 

Problema con Formula

23/03/2009 - 15:47 por Luis Guillermo | Informe spam
A L M P Q
U V X
C4-4007-2008 120 50 32 15 922 170109 23763

Si tengo los siguientes valores, y en X tengo la siguiente Formula:
=SI(DERECHA(A1)=8;U1*(L1+0,5*M1)+P1+(0,5*Q1);23763),porqué me coloca 23763 y
no 133670,que sería el valor correcto. Porqué se me presenta este error.
Gracias por las respuestas.

Gracias.
Luis Guillermo Uribe S.
programasencomputador@gmail.com
programasencomputador@hotmail.com
http://usuarios.lycos.es/asesoriasyprogramas
 

Leer las respuestas

#1 Juan M
23/03/2009 - 16:08 | Informe spam
"Luis Guillermo" escribió
A L M P Q U
V X
C4-4007-2008 120 50 32 15 922 170109 23763

Si tengo los siguientes valores, y en X tengo la siguiente Formula:
=SI(DERECHA(A1)=8;U1*(L1+0,5*M1)+P1+(0,5*Q1);23763),porqué me coloca 23763
y no 133670,que sería el valor correcto. Porqué se me presenta este error.
Gracias por las respuestas.

Gracias.
Luis Guillermo Uribe S.



Hola Luis Guillermo,

El resultado es erróneo porque las funciones derecha, izquierda, extraer
devuelven valores en formato texto.

Para corregir esto, si lo que queremos es comparar con un valor numérico lo
podemos hacer de dos formas:

una entrecomillar el resultado a comparar:
=SI(DERECHA(A1)="8";U1*(L1+0,5*M1)+P1+(0,5*Q1);23763)

la otra es hacer que el resultado de la función derecha sea un número
=SI(--DERECHA(A1)=8;U1*(L1+0,5*M1)+P1+(0,5*Q1);23763)
=SI(DERECHA(A1)*1=8;U1*(L1+0,5*M1)+P1+(0,5*Q1);23763)
=SI(valor(DERECHA(A1))=8;U1*(L1+0,5*M1)+P1+(0,5*Q1);23763)

Un saludo,
Juan

Preguntas similares