Script inexistente abre un nuevo documento en blanco (bueno casi)

21/04/2009 - 13:06 por Pinx0 | Informe spam
Les escribo como webmaster y no como usuario de Internet Explorer para
quejarme acerca de un comportamiento reciente del mismo en mi web (y en
muchas otras no relacionadas conmigo me ha quedado constancia de que ocurre
el mismo problema).

Es algo que afecta única y exclusivamente a su navegador, tanto en la
version 6 y 7 como en la 8.

Ocurre lo siguiente:

La web se carga con normalidad y cuando acaba, parece ser que se ejecuta un
script document.write, que conlleva a mostrar un nuevo document que impide la
visualización de mi web con el siguiente contenido:

<script id=__ie_onload defer src=//0></script>

Esto ha empezado a ocurrir hace pocos días, sin yo haber modificado de
ninguna manera mi código, y para todos los usuarios de su navegador.

Le estoy hablando de que el 52% de mis visitantes no pueden ver mi sitio por
este motivo. Cosa que no afecta como ya digo al resto de navegadores.

Sin embargo, es curioso como ese script invisible que se ejecuta no forma
parte de mi código y tampoco aparece en el código fuente. Simplemente se
ejecuta como por arte de magia, lo que me da a entender que es algo de la
progamación de IE.

Si desactivo el javascript desaparece el problema, pero como comprenderá no
puedo mandar a 5.000 personas que lo desactiven para poder ver mi sitio.

Espero una explicación/solución lo antes posible, porque debido a este más
que sospechoso comportamiento de su navegador, estoy perdiendo más del 50% de
mis visitas, que no son pocas, y eso se traduce en dinero perdido.

Les dejo la dirección por si quieren realizar cualquier tipo de comprobación:

http://www.worldofhouse.es

Un saludo, y gracias por su atención.
 

Leer las respuestas

#1 Linfocito B
21/04/2009 - 14:42 | Informe spam
Hola. Antes que nada, ten en cuenta que esto es un grupo de noticias en
el que se fomenta la participación en comunidad y se basa en la
interacción entre usuarios. Aquí en los grupos en español Microsoft no
da soporte de manera oficial.

Ahora... ¿la has arreglado o algo así? Mira que he podido acceder a tu
página correctamente desde diversas plataformas (XP/Vista/2008) con
todas las versiones de navegador mencionadas. Las herramientas de
depuración y desarrollo de IE8 no me dicen nada sobre tu "script
fantasma"... :-S

Podría inclinarme a pensar que tu plataforma de desarrollo está fallando
o en el peor de los casos, se ha infectado con algún virus.
Igualmente, te recomiendo que utilices la siguiente página, muy útil
para programación web ya que te permite hacer una vista previa real de
páginas por parte de servidores dedicados:
http://browsershots.org/

Atte.: Sergio Andrés Melo
Salu2 desde Bogotá, Colombia.
http://rinconlinfocitario.spaces.live.com/


Pinx0 escribió:
Les escribo como webmaster y no como usuario de Internet Explorer para
quejarme acerca de un comportamiento reciente del mismo en mi web (y en
muchas otras no relacionadas conmigo me ha quedado constancia de que ocurre
el mismo problema).

Es algo que afecta única y exclusivamente a su navegador, tanto en la
version 6 y 7 como en la 8.

Ocurre lo siguiente:

La web se carga con normalidad y cuando acaba, parece ser que se ejecuta un
script document.write, que conlleva a mostrar un nuevo document que impide la
visualización de mi web con el siguiente contenido:

<script id=__ie_onload defer src=//0></script>

Esto ha empezado a ocurrir hace pocos días, sin yo haber modificado de
ninguna manera mi código, y para todos los usuarios de su navegador.

Le estoy hablando de que el 52% de mis visitantes no pueden ver mi sitio por
este motivo. Cosa que no afecta como ya digo al resto de navegadores.

Sin embargo, es curioso como ese script invisible que se ejecuta no forma
parte de mi código y tampoco aparece en el código fuente. Simplemente se
ejecuta como por arte de magia, lo que me da a entender que es algo de la
progamación de IE.

Si desactivo el javascript desaparece el problema, pero como comprenderá no
puedo mandar a 5.000 personas que lo desactiven para poder ver mi sitio.

Espero una explicación/solución lo antes posible, porque debido a este más
que sospechoso comportamiento de su navegador, estoy perdiendo más del 50% de
mis visitas, que no son pocas, y eso se traduce en dinero perdido.

Les dejo la dirección por si quieren realizar cualquier tipo de comprobación:

http://www.worldofhouse.es

Un saludo, y gracias por su atención.

Preguntas similares